Find the answer to your Linux question:
Page 5 of 12 FirstFirst 1 2 3 4 5 6 7 8 9 ... LastLast
Results 41 to 50 of 120
Rexilion, Do you have any further ideas to try?...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #41
    Just Joined!
    Join Date
    Jan 2013
    Posts
    61

    Rexilion,
    Do you have any further ideas to try?

  2. #42
    Linux Newbie
    Join Date
    Jun 2012
    Posts
    100
    Ok... let's go barebone then...

    Try this, everything running as your normal user: (beware, make sure you take precautions we are going to share your entire home dir)

    Code:
    touch ~/.emptyconfig
    /usr/sbin/vsftpd -olisten_port=5555 -opasv_min_port=5556 -opasv_max_port=5557 -oport_enable=NO -olisten=true -orun_as_launching_user=true -oxferlog_enable=false -oanon_world_readable_only=false ~/.emptyconfig
    I just tested this myself with vsftpd 2.3.5 in Gentoo. Connect to port 5555 of localhost (127.0.0.1) to test. You should see a tree of the directory you are running your command in. You should be able to browse, not delete or write.

    Good luck!

  3. #43
    Just Joined!
    Join Date
    Jan 2013
    Posts
    61
    I can connect but I get "Error: Connection closed by server
    Error: Failed to retrieve directory listing" when it tries to get a directory listing

  4. $spacer_open
    $spacer_close
  5. #44
    Linux Newbie
    Join Date
    Jun 2012
    Posts
    100
    The user starting the server must be in a directory of which the contents are accessable to that same user. I guess this is a requirement of this setup. Try again in /tmp or in / maybe?

    EDIT: This is an anonymous setup, no use in logging in or anything like that.

  6. #45
    Just Joined!
    Join Date
    Jan 2013
    Posts
    61
    Ok, when I do that I now get "421 service not available, remote server has closed connection".

  7. #46
    Linux Newbie
    Join Date
    Jun 2012
    Posts
    100
    What version of vsftpd are you using? Above command should work under any condition I'm aware off. Did you change the ports?

  8. #47
    Just Joined!
    Join Date
    Jan 2013
    Posts
    61
    I am using vsFTPd 3.0.0

  9. #48
    Linux Newbie
    Join Date
    Jun 2012
    Posts
    100
    Yeah, you probably got:

    Quote Originally Posted by filezilla
    Antwoord: 500 OOPS: prctl PR_SET_SECCOMP failed
    Manpage mentions nothing about disabling it, but it was in the changelog (thank god...).

    A new commandline, this time including logging to your terminal . Mention one, get two!

    touch ~/.emptyconfig
    touch ./vsftpd.log
    /usr/sbin/vsftpd -olisten_port=5555 -opasv_min_port=5556 -opasv_max_port=5557 -oport_enable=NO \
    -olisten=true -orun_as_launching_user=true -oanon_world_readable_only=false \
    -odual_log_enable=yes -olog_ftp_protocol=yes -ovsftpd_log_file=./vsftpd.log -oxferlog_file=./vsftpd.log \
    -owrite_enable=true -oanon_upload_enable=true -oanon_mkdir_write_enable=true \
    -oanon_other_write_enable=true -oseccomp_sandbox=no ~/.emptyconfig | tail -F ./vsftpd.log
    Last command should work, post any output that it produces and (of course) tell me if it works. Does it still hang?

    Furthermore, it's not nice to leave stray stuff around, so to delete our temporary files you should do:

    rm ~/.emptyconfig
    rm ./vsftpd.log
    In the same directory you started vsftpd earlier.

    I tested all this with vsftpd 3.0.2. Between 3.0 and 3.0.2 only contains some minor fixes. The seccomp sandbox is nice though...

    EDIT: You cannot upload, this is intentional. Since you said the hang also happens at the initial login, this testcase should suffice.
    EDIT2: I just enabled some extra logging and file uploading. Please, DO, try it now.
    Last edited by Rexilion; 02-08-2013 at 12:17 PM.

  10. #49
    Just Joined!
    Join Date
    Jan 2013
    Posts
    61
    I am sorry, but there have been some "exotic" issues that I have been needing to tend to and now they need to be done. I will not be able to complete your requests at least until Monday. I will let you know then.

  11. #50
    Linux Newbie
    Join Date
    Jun 2012
    Posts
    100
    Relax. Don't get scared off my by quick responses. I'm not expecting (nor do I have the right do so) a quick response or anything like that. See ya on monday! (or maybe later hehe). Have a nice weekend!

Page 5 of 12 FirstFirst 1 2 3 4 5 6 7 8 9 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •