Find the answer to your Linux question:
Results 1 to 4 of 4
I am trying to set up a PXE installation for CentOS 5.7 64 bit. I have installed dhcp on the installation server. I've set up /etc/dhcpd.conf with some fairly generic ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2012
    Posts
    14

    Setting up PXE installation


    I am trying to set up a PXE installation for CentOS 5.7 64 bit.

    I have installed dhcp on the installation server.

    I've set up /etc/dhcpd.conf with some fairly generic options, including specifying the filename with the exact path relative to the path given at server_args ie
    filename "/pxelinux.0";

    I have run service dhcpd start

    I have set up a /tftpboot directory including /tftpboot/images/isolinux. This contains vmlinuz and initrd.img and various other files. /the tftpboott directory contains pxelinux.0, mboot.c32 chain.c32, memdisk, menu.c32.

    When I boot another machine elsewhere on the network and choose PXE install, I get the message PXE-E53: No Boot Filename Received.

    What would be some troubleshooting steps? Can I use another machine on the network to detect whether the dhcp is really working?

    Thank you

  2. #2
    Just Joined!
    Join Date
    Nov 2012
    Posts
    14
    might as well post the dhcpd.conf

    ddns-update-style interim;
    allow booting;
    allow bootp;
    option option-128 code 128 = string;
    option option-129 code 129 = text;
    next-server 192.168.6.240;
    filename "pxelinux.0";
    subnet 192.168.6.0 netmask 255.255.255.0 {
    range 192.168.6.226 192.168.6.229;
    option subnet-mask 255.255.255.0;
    option broadcast-address 192.168.6.255;

    option domain-name "zzzz.com";
    option domain-name-servers 165.21.83.88;
    }
    default-lease-time 21600;
    max-lease-time 43200;
    option time-offset -18000;




    and the tftp file

    disable = no
    socket_type = dgram
    protocol = udp
    wait = yes
    user = root
    server = /usr/sbin/in.tftpd
    server_args = -s /tftpboot
    per_source = 11
    cps = 100 2
    flags = IPv4

  3. #3
    Just Joined!
    Join Date
    Oct 2007
    Posts
    22
    Hi,

    have a look on the link, might helpful to you,

    Quick HOWTO : Ch25 : Network-Based Linux Installation - Linux Home Networking

    Chrs,

  4. #4
    Just Joined!
    Join Date
    Nov 2012
    Posts
    14
    Thank you, Chris. I have been following the Centos HowTo guide exactly.
    The DHCPD session is detected straight away when the other machine boots up: it detects the right IP address. Searches for the TFTP session but gets the PXE-E32 TFTP open timeout message.

    If there were merely something wrong with my setup in tftpboot, I would expect a message indicating "file not found". /sbin/chkconfig --list" indicates both xinetd and tftp are running on the server.

    Some way I can use another (already configured) machine to interrogate the server and maybe Isolate the problem>?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •