Find the answer to your Linux question:
Results 1 to 2 of 2
I am trying to use php's mail function to send an email. I have a simple script that does the following (the email address i am using is valid, this ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2013
    Posts
    2

    exim permission denied


    I am trying to use php's mail function to send an email. I have a simple script that does the following (the email address i am using is valid, this forum wont let me post at symbols):
    PHP Code:
    var_dump(mail('example at example.com''test''this is a test')); 
    the output is:
    bool(false)
    and if i check my exim error logs i am getting:
    Failed to create spool file /var/spool/exim/input//1U2rhE-00010B-BI-D: Permission denied
    I've tried all sorts of permissions for exim, but none of them seem to work. This is what i have currently:
    # ll /usr/sbin/exim
    -rwsr-xr-x. 1 root root 1118184 Oct 28 13:32 /usr/sbin/exim
    #ls -ld /var/spool/exim/input
    drwxr-x---. 2 exim exim 4096 Feb 4 10:07 /var/spool/exim/input
    Can anyone offer me any assistance in tracking down where the permission denied error is coming from? Thanks in advance.

  2. #2
    Just Joined!
    Join Date
    Feb 2013
    Posts
    2
    for anyone that is wondering, it as selinux that was blocking the application. i went into /etc/selinux/config and set SELINUX=disabled and restarted the machine and it worked. (a better solution would be to create a proper policy in selinux, but i dont know how to do that)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •