Hi all, so I have this issue where it keeps giving me a syntax error on line 28.

THis is my config file

> #
> # CONFIG FILE FOR SQUIDGUARD
> #
>
> dbhome /usr/local/squidGuard/db
> logdir /usr/local/squidGuard/log
> ldapbinddn uid=jeloff,dc=i-kno,dc=net
> ldapbindpass *************
>
> #
> # TIME RULES:
> # abbrev for weekdays:
> # s = sun, m = mon, t =tue, w = wed, h = thu, f = fri, a = sat
>
> time workhours {
> weekly mtwhf 08:00 - 17:00
> }
>
> #
> # REWRITE RULES:
> #
>
> #
> # SOURCE ADDRESSES:
> #
>
> src users {
> (this is line 28, where the syntax error is) ldapusersearch ldap://my ldap address/ou=people,dc=i-kno,dc=net?uid?sub?(&(objectclass=organizationalPe rson)(uid=%s))
> }
>
> #
> # DESTINATION CLASSES:
> #
>
> dest blocked {
> domainlist blocked/domains
> }
>
>
> acl {
> users within workhours {
> pass !blocked all
> redirect certain url.
> } else {
> pass all
> }
>
> default {
> pass none
> redirect certain url.
> }
> }


This is the error I am getting when I try to run the command squidGuard -C all

> 2013-02-12 16:52:15 [8556] INFO: New setting: dbhome: /usr/local/squidGuard/db
> 2013-02-12 16:52:15 [8556] INFO: New setting: logdir: /usr/local/squidGuard/log
> 2013-02-12 16:52:15 [8556] INFO: New setting: ldapbinddn: uid=jeloff,dc=i-kno,dc=net
> 2013-02-12 16:52:15 [8556] INFO: New setting: ldapbindpass: ***************
> 2013-02-12 16:52:15 [8556] FATAL: syntax error in configfile /usr/local/squidGuard/squidGuard.conf line 28
> 2013-02-12 16:52:15 [8556] ERROR: Going into emergency mode

I am at an end, I cannot for the life of me figure out what the sintax error is.

*Note I have tried adding cn=jeloff infront of ou=people. Also with dn and uid. I have also tried the same but instead of jeloff I have tried squidusers. Nothing worked.

I have also got it working through squid itself, though I'm guessing squidGuard would make it easier to set up rules and such.

Any help would be much appreciated.