Find the answer to your Linux question:
Results 1 to 8 of 8
Fedora 17, LXDE I am trying to add a network printer. It keeps asking for my root password. From what I understand there is no root account in F17. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! TheAlmightyOS's Avatar
    Join Date
    Feb 2009
    Location
    Earth?
    Posts
    42

    Question Can't add network printer: No root password Fedora 17


    Fedora 17, LXDE

    I am trying to add a network printer. It keeps asking for my root password. From what I understand there is no root account in F17. I tried logging with my user and pass and using my pass and the root user. nothing works. Is there a way to enable root or get the add printer dialog to stop asking for the root password?

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,601
    Have you tried sudo? IE, "sudo su -" to get to root. This assumes your user account has sudo privileges. Most Red Hat systems allow root logins, though I don't know about FC17, though once you get in with root privileges you can enable that if you need. So, how did you install this system? The installing user id should have sudo privileges by default.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Jul 2010
    Location
    New Mexico, USA
    Posts
    31
    I agree with rubberman that the 'root' password was established during installation of Fedora 17. If you didn't install it you'll have to get the password from the person who did install it.

  4. #4
    Just Joined! TheAlmightyOS's Avatar
    Join Date
    Feb 2009
    Location
    Earth?
    Posts
    42
    well, I was hoping that someone who actually USED Fedora17 would answer (because, no, Fedora17 has root disabled. I installed it myself. Look it up). During install you create a User and that users' password is used for many purposes that on other distros would require root privileges such as installing packages and accessing system files. HOWEVER, this user is not "root". When using the GUI to add a printer it wants the root user. I can not sudo in an dialog box. And because there is no root user in Fedora17, it just goes in an endless loop.

    But nevermind, I think I might switch distros again because I never liked not having a separate root account. I consider it unsafe and is the same reason I refuse to use uborgtu. I can't find a distro that works well on this craptop anyway. I might end up going with windowsxp

  5. #5
    Linux Newbie ryptyde's Avatar
    Join Date
    Apr 2005
    Location
    Tragic City Michigan USA
    Posts
    235
    When I installed Fedora 17 and previous Fedoras there was a point in the install to create
    root password. If you have root disabled it is because you disabled it or let's just say there was
    a bug in the installer and root was not created.

    So as a current Fedora 17 user I would recommend that you start in "run level 1" and to do that
    when you get to the grub menu press "e" to edit the boot parameters and at the end of the kernel
    line that contains "rhgb quiet" leave a space and add the number 1. You will then be root #. Then
    enter "passwd" without the quotes. Enter the new password and it will ask to enter it again to confirm.
    You now have new root password. Now reboot and login as regular user. When you need to use root
    privileges your new password should work if not reply back with details.

  6. #6
    Just Joined! TheAlmightyOS's Avatar
    Join Date
    Feb 2009
    Location
    Earth?
    Posts
    42
    Quote Originally Posted by ryptyde View Post
    When I installed Fedora 17 and previous Fedoras there was a point in the install to create
    root password. If you have root disabled it is because you disabled it or let's just say there was
    a bug in the installer and root was not created.

    So as a current Fedora 17 user I would recommend that you start in "run level 1" and to do that
    when you get to the grub menu press "e" to edit the boot parameters and at the end of the kernel
    line that contains "rhgb quiet" leave a space and add the number 1. You will then be root #. Then
    enter "passwd" without the quotes. Enter the new password and it will ask to enter it again to confirm.
    You now have new root password. Now reboot and login as regular user. When you need to use root
    privileges your new password should work if not reply back with details.
    Ok, I ran the !-EXPLETIVE-! in a VM just to make sure I am not going nuts. The LXDE ISO I have DOES NOT have a place to put a root password on install. The KDE ISO I have however does. So it isn't F17 per say, just the !-EXPLETIVE-! LXDE version.

    Screw it, installing the KDE version. Hope it don't kill this laptop. Only has a gig of ram.

  7. #7
    Linux Newbie ryptyde's Avatar
    Join Date
    Apr 2005
    Location
    Tragic City Michigan USA
    Posts
    235
    Glad to hear you are making some headway. Fedora 18 is running well here also on
    an Acer Aspire One and Sony laptop installed them both from a live usb. I also created
    a Fedora live spin with MATE desktop environment from a kickstart file from the Fedora
    Project site. A MATE spin is scheduled to be a Fedora release in F19.

  8. #8
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,601
    As the installing user, you should have sudo privileges: sudo su -
    That should put you into root account mode.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •