Find the answer to your Linux question:
Results 1 to 9 of 9
Hi, I have problem rebooting my RHEL 4.3 server. When I reboot, it takes > 5 hours to reboot!!! This is what I get when I do the nslookup for ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Dec 2009
    Posts
    106

    Very slow reboot


    Hi,

    I have problem rebooting my RHEL 4.3 server.

    When I reboot, it takes > 5 hours to reboot!!!

    This is what I get when I do the nslookup for this server :

    Code:
    C:\Documents and Settings\TEMP>nslookup kl-linux01
    Server:  mydc.persistent.co.in
    Address:  10.211.224.100
    
    Name:    kl-linux01.persistent.co.in
    Address:  10.212.4.35
    
    
    C:\Documents and Settings\TEMP>
    What could be the reason?? Could it be something to do with the hostname??

  2. #2
    Trusted Penguin Irithori's Avatar
    Join Date
    May 2009
    Location
    Munich
    Posts
    3,440
    Quote Originally Posted by anaigini45 View Post
    Could it be something to do with the hostname??
    No, what makes you think that?

    What could have happened is, that the machine hasnt been rebooted in a long time
    and as it was, it enforced a filesystemcheck.
    In that case the next reboot should be faster.


    Other than that:
    rhel 4.3 is end of life. You should consider installing a current rhel 6.4 on a different machine and then migrating your services and data.
    https://en.wikipedia.org/wiki/Redhat...fe-cycle_dates
    You must always face the curtain with a bow.

  3. #3
    Linux Newbie
    Join Date
    Dec 2009
    Posts
    106
    I had rebooted the machine several times, and it is still the same speed at the new reboot.




    Also, I notice that it gets stuck for a very long time at anything to do with NFS, like 'Starting NFS startd', etc etc.

    and also this :

    Starting ITMAAgents1
    Starting ITMAAgents2

    Is it an NFS issue also?

  4. $spacer_open
    $spacer_close
  5. #4
    Trusted Penguin Irithori's Avatar
    Join Date
    May 2009
    Location
    Munich
    Posts
    3,440
    So what happens at reboot?
    At which stage does it take so much time?
    You must always face the curtain with a bow.

  6. #5
    Trusted Penguin Irithori's Avatar
    Join Date
    May 2009
    Location
    Munich
    Posts
    3,440
    5h seems excessive for nfs issues alone.
    But if your nfs server(s) have issues and they are needed for startup, then this can cause some slowdown.

    What are ITMAAgents?
    You must always face the curtain with a bow.

  7. #6
    Linux Engineer
    Join Date
    Apr 2012
    Location
    Virginia, USA
    Posts
    917
    You definitely should check your boot log, /var/log/messages, and dmesg.

    If you suspect NFS is the problem, try commenting out those entries in /etc/fstab or autofs. You can also add a timeout value to the NFS mounts.

  8. #7
    Just Joined!
    Join Date
    Nov 2008
    Posts
    34
    Please check the IP mentioned in the /etc/exports , find out whether its reachable through network , NFS server usually waits on port 2049 ,
    Try simple telnet command to check host is waiting on port 2049
    Try switching off the ITMAAGNTS service if its not critical

    Thanks
    Philix

  9. #8
    Linux Newbie
    Join Date
    Dec 2009
    Posts
    106
    Quote Originally Posted by philix View Post
    Please check the IP mentioned in the /etc/exports , find out whether its reachable through network , NFS server usually waits on port 2049 ,
    Try simple telnet command to check host is waiting on port 2049
    Try switching off the ITMAAGNTS service if its not critical

    Thanks
    Philix
    I do not have the login for this server. How do I stop the nfs and the ITMAAGNTS service at boot, without logging into the server?

  10. #9
    Linux Newbie
    Join Date
    Dec 2009
    Posts
    106
    I attempted to disable the nfs service by running this command :

    Code:
    #chkconfig nfs off
    Then I rebooted the system. But still this line pops up during the boot process, and it gets stuck there for some time (5 - 15 minutes) :

    HTML Code:
    Starting NFS statd
    Why is this so?? Doesn't disabling the NFS service disrupt/cancel anything to do with NFS?? Why does is still attempt to start NFS statd??

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •