Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, When I boot my RHEL 4.3 box, all the services are started during boot. For services like NFS, I can use Code: #chkconfig nfs off to disable and prevent ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Dec 2009
    Posts
    106

    Stopping ITMAgents1 & 2 during boot


    Hi,

    When I boot my RHEL 4.3 box, all the services are started during boot. For services like NFS, I can use
    Code:
    #chkconfig nfs off
    to disable and prevent it from starting during boot.

    However, ITMAgents1 does not recognize chkconfig.

    How do I disable ITMAgents1 & ITMAgents2 so that it does not start up during boot?? Do I have to do something with /etc/rcX.d??

    I also realise that any service that is related to NFS or has the word NFS in it, like Starting NFS statd, Starting NFS mountd, etc, etc, always takes a very long time to start during boot. (More than 30 mins for each). This is the reason I want to disable the service. The same goes to ITMAgents.

    Thanks,
    ana

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by anaigini45 View Post
    How do I disable ITMAgents1 & ITMAgents2 so that it does not start up during boot?? Do I have to do something with /etc/rcX.d??

    I also realise that any service that is related to NFS or has the word NFS in it, like Starting NFS statd, Starting NFS mountd, etc, etc, always takes a very long time to start during boot. (More than 30 mins for each). This is the reason I want to disable the service. The same goes to ITMAgents.
    It appears that it does not support chkconfig. See here. You'll have to manually edit the files, or simply move them to another dir.

  3. #3
    Linux Newbie
    Join Date
    Dec 2009
    Posts
    106
    Can you please give an example of how to manually edit the files OR move them to another directory??
    In the link that you gave me, this was given :

    PHP Code:
    In order to do disable auto-start you have to comment out the line related to the agent:

     
    EGKXX in the /etc/rc.itm*  ( check every file named
    itm
    *** ).

    In example,the line for the KSA (mySAP Agentis like the following:
    /
    usr/bin/su root -" /opt/IBM/ITM/bin/itmcmd agent start sa
    >/dev/null 2>&1" 
    However, I can't find /etc/rc.itm* in the Linux box. The closest I can relate is the /etc/rcX.d. When I go into this directory, e.g /etc/rc2.d, then I can find lines with ITMAgents1 and ITMAgents2. Is this where I can edit stuff??

    Please provide me an example of how to edit the files....or any other suggested way.

    Thanks,
    ana

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by anaigini45 View Post
    Can you please give an example of how to manually edit the files OR move them to another directory??
    In the link that you gave me, this was given :

    PHP Code:
    In order to do disable auto-start you have to comment out the line related to the agent:

     
    EGKXX in the /etc/rc.itm*  ( check every file named
    itm
    *** ).

    In example,the line for the KSA (mySAP Agentis like the following:
    /
    usr/bin/su root -" /opt/IBM/ITM/bin/itmcmd agent start sa
    >/dev/null 2>&1" 
    However, I can't find /etc/rc.itm* in the Linux box. The closest I can relate is the /etc/rcX.d. When I go into this directory, e.g /etc/rc2.d, then I can find lines with ITMAgents1 and ITMAgents2. Is this where I can edit stuff??

    Please provide me an example of how to edit the files....or any other suggested way.

    Thanks,
    ana

    open a terminal window, and try something like this:
    Code:
    # first, su to root (you'll be prompted for the password)
    su -
    
    # make a dir to contain disabled scripts/links:
    mkdir /etc/rc.DISABLED
    
    # then find files in the init dir and move them to the disabled dir
    find /etc/rc* -iname '*itma*' -exec echo mv -v {} /etc/rc.DISABLED/ \;
    if the find command found files, you should see a "mv" command echoed to the terminal. this command does not actually move any files. if the files it found looks right, run the find command again, and just remove the "echo" from the line, e.g.:
    Code:
    find /etc/rc* -iname '*itma*' -exec mv -v {} /etc/rc.DISABLED/ \;
    btw, if you want to keep track of what got moved and from where, use this logging version of the above command:
    Code:
    find /etc/rc* -iname '*itma*' -exec mv -v {} /etc/rc.DISABLED/ \; > /tmp/itmagent-files.log 2>&1
    if this is run, then files that got moved will be recorded in the file /tmp/itmagent-files.log.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •