Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
I am pretty much a newbie to RHEL. We have a system that has been locked down to meet company security requirements, but have been requested to allow users to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2011
    Location
    TN, USA
    Posts
    6

    Unable to burn CD from GNOME


    I am pretty much a newbie to RHEL. We have a system that has been locked down to meet company security requirements, but have been requested to allow users to burn CDs. In addition to root, the system has one user ("usrlocal"). If logged in as root, we are able to mount a blank CD, drop files and burn. If logged in as "usrlocal", we can mount the CD, drag/drop the files and then click the "Write to Disc" button. But once we click "Write" on the next dialog, we immediately get "Error writing to disc", "There was an error writing to the disc".

    I have added the user to sudoers as follows, but still no luck.

    usrlocal All=/sbin/mount, /bin/mount, /sbin/umount, /bin/umount, /usr/bin/cdrecord

    Any ideas would be appreciated.

  2. #2
    Linux Newbie
    Join Date
    Aug 2010
    Posts
    234
    You might not have the user in the CD group.
    To view what groups the user is in code #id "user"
    If the user is not in the optical group
    code #gpasswd -a "user" optical
    also make sure they are in the wheel group so they can use sudo.
    Last edited by electroman6913; 04-02-2013 at 09:36 PM.

  3. #3
    Just Joined!
    Join Date
    Sep 2011
    Location
    TN, USA
    Posts
    6
    Quote Originally Posted by electroman6913 View Post
    You might not have the user in the CD group.
    To view what groups the user is in code #id "user"
    If the user is not in the optical group
    code #gpasswd -a "user" optical
    also make sure they are in the wheel group so they can use sudo.
    Thank you for the response.

    I don't see a CD, or optical, group. Did confirm the usrlocal account is a member of Wheel.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Aug 2010
    Posts
    234
    The cd group is called optical just add optical group to the user.

  6. #5
    Linux Newbie
    Join Date
    Aug 2010
    Posts
    234
    here is a wiki on users and groups
    https://wiki.archlinux.org/index.php/Users_and_Groups

  7. #6
    Just Joined!
    Join Date
    Sep 2011
    Location
    TN, USA
    Posts
    6
    Quote Originally Posted by electroman6913 View Post
    here is a wiki on users and groups
    Thanks for the link. I had just found that.

    Unfortunately for me, this system does not have an "optical" group. Perhaps it was scrubbed by mistake during the security lock down.

  8. #7
    Linux Newbie
    Join Date
    Aug 2010
    Posts
    234
    # groupadd optical

  9. #8
    Linux Newbie
    Join Date
    Aug 2010
    Posts
    234
    Next time you set up a user and need to restrict them it might be easier to do it via terminal and follow the wiki in the link I gave you before.

  10. #9
    Just Joined!
    Join Date
    Sep 2011
    Location
    TN, USA
    Posts
    6
    Looks like sr0 has:

    brw- r----- 1 root disk 11

    If I chmod sr0 to 660, and add my user to the "disk" group, everything works as expected (I can record to the drive without error). Unfortunately, when I reboot the system, sr0 is changed back to 640.

  11. #10
    Just Joined!
    Join Date
    Sep 2008
    Location
    Earth
    Posts
    51
    quick and dirty add your chmod command to /etc/rc.local so its executed at reboot, or create a cronjob with @reboot as time period.
    The other option is to use MODE=permissions you want in a custom udev rule for that device.
    http://www.reactivated.net/writing_udev_rules.html

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •