Find the answer to your Linux question:
Results 1 to 2 of 2
I am able to mount samba but it just won't mount when i reboot system what is stopping it from mounting after reboot? I mounted before reboot but right after ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2013
    Posts
    9

    samba won't mount after reboot...please help


    I am able to mount samba but it just won't mount when i reboot system
    what is stopping it from mounting after reboot?


    I mounted before reboot but right after reboot...i ran mount
    Code:
    [root@vm3 ~]# mount
    /dev/mapper/vg_sda2-lv_root on / type ext4 (rw)
    proc on /proc type proc (rw)
    sysfs on /sys type sysfs (rw)
    devpts on /dev/pts type devpts (rw,gid=5,mode=620)
    tmpfs on /dev/shm type tmpfs (rw,rootcontext="system_u:object_r:tmpfs_t:s0")
    /dev/sda1 on /boot type ext4 (rw)
    none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
    sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
    nfsd on /proc/fs/nfsd type nfsd (rw)
    /dev/sr0 on /media/VBOXADDITIONS_4.2.12_84980 type iso9660 (ro,nosuid,nodev,uhelper=udisks,uid=500,gid=500,iocharset=utf8,mode=0400,dmode=0500)
    When i remount..it worked..so why not work after reboot???
    Code:
    [root@vm3 ~]# findsmb
    
                                    *=DMB
                                    +=LMB
    IP ADDR         NETBIOS NAME     WORKGROUP/OS/VERSION 
    ---------------------------------------------------------------------
    192.168.1.38    VM3           +[MYGROUP] [Unix] [Samba 3.6.9-151.el6]
    [root@vm3 ~]# mount -t cifs //LOCALHOST/samba /samba-mount -v -o user=BUSARI,password=dadon4u
    mount.cifs kernel mount options: ip=::1,unc=\\LOCALHOST\samba,,ver=1,user=BUSARI,pass=********
    [root@vm3 ~]# mount
    /dev/mapper/vg_sda2-lv_root on / type ext4 (rw)
    proc on /proc type proc (rw)
    sysfs on /sys type sysfs (rw)
    devpts on /dev/pts type devpts (rw,gid=5,mode=620)
    tmpfs on /dev/shm type tmpfs (rw,rootcontext="system_u:object_r:tmpfs_t:s0")
    /dev/sda1 on /boot type ext4 (rw)
    none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
    sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
    nfsd on /proc/fs/nfsd type nfsd (rw)
    /dev/sr0 on /media/VBOXADDITIONS_4.2.12_84980 type iso9660 (ro,nosuid,nodev,uhelper=udisks,uid=500,gid=500,iocharset=utf8,mode=0400,dmode=0500)
    //LOCALHOST/samba on /samba-mount type cifs (rw)
    [root@vm3 ~]# service smb status
    smbd (pid  2014) is running...
    [root@vm3 ~]# service nmb status
    nmbd (pid  2006) is running...
    [root@vm3 ~]# findsmb
    
                                    *=DMB
                                    +=LMB
    IP ADDR         NETBIOS NAME     WORKGROUP/OS/VERSION 
    ---------------------------------------------------------------------
    192.168.1.38    VM3           +[MYGROUP] [Unix] [Samba 3.6.9-151.el6]
    [root@vm3 ~]# testparm -L
    Load smb config files from /etc/samba/smb.conf
    rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
    Processing section "[homes]"
    Processing section "[printers]"
    Processing section "[samba]"
    Loaded services file OK.
    Server role: ROLE_STANDALONE
    Press enter to see a dump of your service definitions
    
    [global]
    	workgroup = MYGROUP
    	server string = Samba Server Version %v
    	log file = /var/log/samba/log.%m
    	max log size = 50
    	idmap config * : backend = tdb
    	cups options = raw
    
    [homes]
    	comment = Home Directories
    	read only = No
    	browseable = No
    
    [printers]
    	comment = All Printers
    	path = /var/spool/samba
    	printable = Yes
    	print ok = Yes
    	browseable = No
    
    [samba]
    	comment = Samba
    	path = /share/samba
    	read only = No
    	guest ok = Yes
    [root@vm3 ~]# cat /etc/fstab
    
    #
    # /etc/fstab
    # Created by anaconda on Thu May  2 20:30:24 2013
    #
    # Accessible filesystems, by reference, are maintained under '/dev/disk'
    # See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
    #
    /dev/mapper/vg_sda2-lv_root /                       ext4    defaults        1 1
    UUID=cf27ea89-2bef-4ae8-8b98-083e6a27f5bf /boot                   ext4    defaults        1 2
    /dev/mapper/vg_sda2-lv_swap swap                    swap    defaults        0 0
    tmpfs                   /dev/shm                tmpfs   defaults        0 0
    devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
    sysfs                   /sys                    sysfs   defaults        0 0
    proc                    /proc                   proc    defaults        0 0
    192.168.1.38:/share/nfs /nfs-mount              nfs     defaults        0 0
    //LOCALHOST/samba       /samba-mount            smbfs   username=BUSARI,password=dadon4u    0 0

  2. #2
    Just Joined!
    Join Date
    Dec 2012
    Posts
    30
    I had the same problem. IIRC, I think it is a timing issue during the startup process - some service that samba needs hasn't loaded yet when samba tries to load. I fixed it on my Fedora 16 box by creating a /etc/rc.d/rc.local file, and adding this command:
    Code:
    sudo systemctl restart smb.service

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •