Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 26
I upgraded to F18 a few weeks ago. I think was working OK. I ran several updates and was up to 3.8.3-203. I think it was the next time I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    36

    Upgraded Fedora 18 and Now Won't Boot


    I upgraded to F18 a few weeks ago. I think was working OK. I ran several updates and was up to 3.8.3-203. I think it was the next time I powered up after this update that the problem started. It starts to boot up, but, stalls when it gets to the point where there is an f in a circle in the middle of a blue screen. Also,I there was a problem shutting down one time. I don’t remember if it was the time before started. There were errors when shutting down and the system hung. had to shut down with the power switch. I tried to boot with 3.8.3-201 and 3.6.2-206, but, it still had the problem.

    I saw other people had similar problems and it seems to be a video driver problem. I could get into a terminal by pressing cntrl-alt-shft I. I tried running lshw at the command prompt to find my video card info, but the letters that showed up on the screen weren’t the ones I entered. I.I can also get in the grub command line, but, lshw isn’t one of the available commands. I have a Leno voice r61i laptop.

    Someone suggested that I press F12 to see the terminal output before it stalls. I get an error: [FAILED] Failed to start Wait for Plymouth Boot Screen to Quit.
    See ‘systemmctl status plymouth-quit-wait. service’ for details. and there are other things on the screen as well.

    I couldn’t get the video card/driver information with linux due to not being able to boot, but, I put a Windows HD in and got the video card info:

    —————
    Display Devices
    —————
    Card name: Mobile Intel(R) 965 Express Chipset Family
    Manufacturer: Intel Corporation
    Chip type: Mobile Intel(R) 965 Express Chipset Family
    DAC type: Internal
    Device Key: EnumPCIVEN_8086&DEV_2A02&SUBSYS_20B517AA&REV_0C
    Display Memory: 358 MB
    Dedicated Memory: 0 MB
    Shared Memory: 358 MB
    Current Mode: 1280 x 800 (32 bit) (60Hz)
    Monitor Name: Generic PnP Monitor
    Monitor Model: unknown
    Monitor Id: CMO1526
    Native Mode: 1280 x 800(p) (59.910Hz)
    Output Type: Internal
    Driver Name: igdumd64.dll,igd10umd64.dll,igdumdx32,igd10umd32
    Driver File Version: 8.14.0010.1930 (English)
    Driver Version: 8.15.10.1930
    DDI Version: 10
    Driver Model: WDDM 1.1
    Driver Attributes: Final Retail
    Driver Date/Size: 9/23/2009 20:22:58, 5472256 bytes
    WHQL Logo’d: Yes
    WHQL Date Stamp:
    Device Identifier: {D7B78E66-6942-11CF-9073-BF00ADC2C535}
    Vendor ID: 0×8086
    Device ID: 0x2A02
    SubSys ID: 0x20B517AA
    Revision ID: 0x000C
    Driver Strong Name: oem1.inf:Intel.Mfg.NTamd64:i965GM0:8.15.10.1930civen_8086&dev_2a02
    Rank Of Driver: 00EC2001
    Video Accel: ModeMPEG2_A ModeMPEG2_C ModeWMV9_B ModeVC1_B

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Hi,

    Try appending these kernel parameters to your default kernel at the boot prompt (grub prompt):

    Code:
     vga=normal nomodeset

  3. #3
    Just Joined!
    Join Date
    Jan 2007
    Posts
    36
    I’m not exactly sure what you meant by the grub boot prompt. I think it is where I would select which kernel to boot to. Below is a description of what I did to make sure what I did was what you suggested and the output I got:

    When I reached the grub boot prompt I pressed e (or maybe it was c, I don’t remember right now) and entered “vga=normal nomodeset” in the first line right before “lload_video” and then pressed F10 to boot.

    The boot stalled at the point where there is an f in a circle in the middle of the screen. I then pressed f12 to see the terminal output.

    Below are the lines on the screen when it stalled. I had to transcribe this to my phone, so there could be some typos:

    Code:
    [FAILED] Failed to start GNOME Display Manager.
    See 'Systemmctl status gdm.service'  for details.
    Starting WPA Supplicant daemon...
    [OK]  Started WPA Supplicant daemon.
    [OK]  Started NFS file locking service...
    Stopping GNOME Display Manager...
    [OK]  Stopped GNOME Display Manager.
    Starting GNOME Display Manager...
    [FAILED]  Failed to start GNOME. Display Manager.
    See 'Systemmctl status gdm. service'  for details.
    [OK]  Started NFS Server.
    Starting NFS Mount Daemon...
    Starting NFS Remote Quota Server...
    Starting NFSv4 ID-name mapping daemon...
    [OK]  Started Sendmail Mail Transport Client.
    [OK]  Started NFSv4 ID-name mapping daemon.
    [OK] Started NFS Remote Quota Server.
    Stopping  GNOME Display Manager...
    [OK]  Stopped GNOME Display Manager.
    Starting GNOME Display Manager...
    [FAILED]  Failed to start GNOME Display Manager.
    See 'Systemmctl status gdm.service'  for details.
    [OK]  Started LSB:Crashplan Engine.
    Starting SYSV: vpnagentd is used for managing the Cisco vpn client data path...
    [OK]  Started NFS Mount Daemon
    [OK]  Started SYSV: vpnagentd is used for managing the cisco vpn client data path..
    Starting /etc/rc.d/re . local Compatibility...
    [OK]  Started /etc/rc.d.local Compatibility.
    Starting Wait for Plymouth Boot Screen to Quit...
    [FAILED]  Failed to start Wait for Plymouth Boot Screen to Quit.
    See 'systemmctl status plymouth-quit-wait.service'  for details.
    Starting Getty on tty5...
    [OK] Started Getty on tty5.
    Starting Getty on tty2...
    [OK] Started Getty on tty20.
    Starting Getty on tty3...
    [OK] Started Getty on tty3.
    Starting Getty on tty4...
    [OK] Started Getty on tty4.
    Starting Getty on tty6...
    [OK]  Started Getty on tty6.
    [OK]  Reached target Login Prompts.
    [OK] Reached target Mylti-User.
    [OK] Reached target Graphical Interface.
    Last edited by atreyu; 05-08-2013 at 01:52 AM. Reason: added CODE tags to aid in readability

  4. $spacer_open
    $spacer_close
  5. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by tmort View Post
    I’m not exactly sure what you meant by the grub boot prompt. I think it is where I would select which kernel to boot to.
    you've got it. i should have been more clear, sorry.

    Quote Originally Posted by tmort View Post
    I had to transcribe this to my phone
    cripes! you are a man among men, sir.

    can you get to a console login? Press Ctrl+Alt+F2 to see if it will switch you over to a virtual screen (white text on black background). there should be a login prompt. log in as root and run these commands:
    Code:
    systemctl status gdm.service
    systemctl status plymouth-quit-wait.service
    hopefully, they will provide some more insight. also check the syslog for info:

    Code:
    cat /var/log/messages
    you could also check the XOrg log file:
    Code:
    cat /var/log/Xorg.0.log

  6. #5
    Just Joined!
    Join Date
    Jan 2007
    Posts
    36
    I hope someone is still looking at this thread. I've been very busy...

    I tried pressing cntrl/alt/f2 and I did get a virtual screen with a login prompt. I attempted to login as root by typing root, pressing enter and then entering my root password. I got an incorrect password message. I tried numerous times all with the same result. I also tried logging in as me and that didn't work either. I also tried typing "root" as the password and also simply pressing enter instead of a password, none of which worked.

    I also thought I might be able to boot up with a live cd and look at the logs, but, was unable to view the hard drive.

    Any ideas?

    I imagine F19 has been released. Is there a way I can upgrade/repair my system while broken to it?

    Thanks

  7. #6
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by tmort View Post
    I hope someone is still looking at this thread. I've been very busy...

    I tried pressing cntrl/alt/f2 and I did get a virtual screen with a login prompt. I attempted to login as root by typing root, pressing enter and then entering my root password. I got an incorrect password message. I tried numerous times all with the same result. I also tried logging in as me and that didn't work either. I also tried typing "root" as the password and also simply pressing enter instead of a password, none of which worked.
    you should be able to log in, provided you are using the correct passwords. if you need to log in as root, without using the root password, that is possible: use the kernel boot paramter " 1" at the grub prompt. you enter it at boot time as discussed earlier. just append it to the end of the args. it should boot you straight to a prompt (a "# sign). you are now root.

    I also thought I might be able to boot up with a live cd and look at the logs, but, was unable to view the hard drive.
    you should be able to do that. find the disks using this command:
    Code:
    fdisk -l
    then, say the drive is "sda", and has a few partitions. you might do:
    Code:
    mkdir /mnt/drive
    mount -t auto -o ro /dev/sda1 /mnt/drive
    that is just an example, your drive might not be sda.

    I imagine F19 has been released. Is there a way I can upgrade/repair my system while broken to it?
    Fedora 19 beta has been released, but i would not try upgrading Fedora. If you have any important files, get those backed up, and then do a clean install of Fedora 19 beta.

  8. #7
    Just Joined!
    Join Date
    Jan 2007
    Posts
    36

    F18 Boot Problems

    From root when I get:

    I finally got a little time with no distractions.

    # systemctl status gdm.service
    gdm. service - GNOME Display Manager
    Loaded: loaded (/usr/lib/systemd/system/gdm.service; enabled)
    Active: inactive (dead)

    # systemctl status plymouth-quit-wait.service
    plymouth-quit-wait.service - Wait for Plymouth Boot Screen to Quit
    Loaded: loaded (/usr/lib/systemd/system/plymouth-quit-wait.service; static
    Active: inactive (dead)


    I've attached the dmesg file from /var/logs/messages.

    I forgot to do cat /var/log/Xorg.0.log

    Does this shed any light on what is happening and how to fix it?
    Attached Files Attached Files

  9. #8
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,651
    That looks like a start up log. Have a look at this for capturing the shut down log
    "I used to be with it, then they changed what it was.
    Now what was it isn't it, and what is it is weird and scary to me.
    It'll happen to you too."

    Grandpa Simpson



    The Fifth Continent

  10. #9
    Just Joined!
    Join Date
    Jan 2007
    Posts
    36
    The thread is confusing. So I should write a script with:


    #!/bin/sh
    mount / -orw,remount
    dmesg > /dmesg.shutdown
    mount / -oro,remount

    (script called dmesg_on_shutdown)and booted with kernel options systemd.log_level=debug and systemd.log_target=kmsI then booted with the same options and did

    Shut down and reboot with options:

    sleep 10; /lib/systemd/system-shutdown/dmesg_on_shutdown &
    sync
    halt
    unmounted /dev/hugepages?

  11. #10
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by tmort View Post
    # systemctl status gdm.service
    gdm. service - GNOME Display Manager
    Loaded: loaded (/usr/lib/systemd/system/gdm.service; enabled)
    Active: inactive (dead)

    # systemctl status plymouth-quit-wait.service
    plymouth-quit-wait.service - Wait for Plymouth Boot Screen to Quit
    Loaded: loaded (/usr/lib/systemd/system/plymouth-quit-wait.service; static
    Active: inactive (dead)
    hmm...those are pretty much useless.

    I've attached the dmesg file from /var/logs/messages.
    according to that log, you did not pass the "vga=normal nomodeset" arguments. see this bit from your log:

    Code:
    [    0.000000] Kernel command line: BOOT_IMAGE=/vmlinuz-3.8.3-203.fc18.i686.PAE root=/dev/mapper/VolGroup-lv_root ro rd.md=0 rd.dm=0 rd.lvm.lv=VolGroup/lv_swap KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.lvm.lv=VolGroup/lv_root rd.luks=0 LANG=en_US.UTF-8 1
    try doing that in grub again. also, go ahead and remove the quiet and rhgb options, too.

    I forgot to do cat /var/log/Xorg.0.log
    that's probably the most important one, so when you can, attach that one, too.

    one last thing, I see that SELinux is enabled. just for the hell of it, disable that too at the grub prompt. add this kernel option:
    Code:
    selinux=0

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •