Find the answer to your Linux question:
Results 1 to 10 of 10
Hi all I just installed latest updates to Fedora 18 and my keyboard backlit is stopped working. Was working before, what can I do to get it to work again? ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2013
    Posts
    47

    Keyboard Backlit


    Hi all

    I just installed latest updates to Fedora 18 and my keyboard backlit is stopped working. Was working before, what can I do to get it to work again?

    My computer is an ASUS N56VJ

    Thanks

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    hey,

    Try one of the fixes reported here. it basically involves passing an option to a kernel module that has to do with keyboard backlight at boot time.

  3. #3
    Just Joined!
    Join Date
    Jan 2013
    Posts
    47
    thank you for the response, from the link:

    I can restore the keyboard backlight by changing the value in /sys/devices/platform/sony-laptop/kbd_backlight from 0 to 1, but it changes back to zero after rebooting. The same thing happens to /sys/module/sony_laptop/parameters/kbd_backlight.
    I was not able to find kbd_backlight file

    Added file sony-laptop.conf with single line

    options sony-laptop kbd_backlight=1

    to /etc/modprobe.d/ and it seems to work fine now.

    created file asus-laptop.conf with the above mentioned line and did not work

  4. $spacer_open
    $spacer_close
  5. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    sorry, i didn't notice your laptop is an ASUS, no wonder that didn't work.

    check out this bug report, comment #3. perhaps that will work, worth a try anyway.

  6. #5
    Just Joined!
    Join Date
    Jan 2013
    Posts
    47
    Thank you. I tried the first script they provided, but no luck

    Also, the package they say is working is Debian based, which I believe it will not install in Fedora since Fedora is not Debian based (correct me if I am wrong).

  7. #6
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by jgezau View Post
    Also, the package they say is working is Debian based, which I believe it will not install in Fedora since Fedora is not Debian based (correct me if I am wrong).
    correct, it would not work. or at least, probably not. i do not see a Fedora version of that package, either. however, i do see a kernel module (described at the end of this thread) that you ought to try:

    Code:
    modprobe asus-nb-wmi

  8. #7
    Just Joined!
    Join Date
    Jan 2013
    Posts
    47
    It kinda worked, thanks.

    I was showing the same error as in the other thread

    Code:
    [root@localhost leds]# dmesg | grep asus
    [    8.583052] asus_wmi: ASUS WMI generic driver loaded
    [    8.605138] asus_wmi: Initialization: 0x1
    [    8.605173] asus_wmi: BIOS WMI version: 7.9
    [    8.605216] asus_wmi: SFUN value: 0x6a0877
    [    8.605816] input: Asus WMI hotkeys as /devices/platform/asus-nb-wmi/input/input10
    [    8.692211] asus-nb-wmi: probe of asus-nb-wmi failed with error -5
    And running

    Code:
    [root@localhost leds]# ls -l /sys/class/leds
    total 0
    lrwxrwxrwx. 1 root root 0 May 23 08:34 phy0-led -> ../../devices/pci0000:00/0000:00:1c.1/0000:03:00.0/leds/phy0-led

    After running
    Code:
    modprobe asus-nb-wmi
    I got

    Code:
    [root@localhost leds]# dmesg | grep asus
    [    8.583052] asus_wmi: ASUS WMI generic driver loaded
    [    8.605138] asus_wmi: Initialization: 0x1
    [    8.605173] asus_wmi: BIOS WMI version: 7.9
    [    8.605216] asus_wmi: SFUN value: 0x6a0877
    [    8.605816] input: Asus WMI hotkeys as /devices/platform/asus-nb-wmi/input/input10
    [    8.692211] asus-nb-wmi: probe of asus-nb-wmi failed with error -5
    [21320.024189] asus_wmi: Initialization: 0x1
    [21320.024244] asus_wmi: BIOS WMI version: 7.9
    [21320.024310] asus_wmi: SFUN value: 0x6a0877
    [21320.025959] input: Asus WMI hotkeys as /devices/platform/asus-nb-wmi/input/input14
    [21320.069613] asus_wmi: Backlight controlled by ACPI video driver
    
    [root@localhost leds]# ls -l /sys/class/leds
    total 0
    lrwxrwxrwx. 1 root root 0 May 24 10:08 asus::kbd_backlight -> ../../devices/platform/asus-nb-wmi/leds/asus::kbd_backlight
    lrwxrwxrwx. 1 root root 0 May 24 10:08 asus::wlan -> ../../devices/platform/asus-nb-wmi/leds/asus::wlan
    lrwxrwxrwx. 1 root root 0 May 23 08:34 phy0-led -> ../../devices/pci0000:00/0000:00:1c.1/0000:03:00.0/leds/phy0-led
    Now, I noticed when I press FN+[F3][F4] I get the keyboard brightness graphic on the screen, but that is about it. It has not effect on the lighting. I have to run the following to turn the light on

    Code:
    [root@localhost leds]# echo 10 | tee asus\:\:kbd_backlight/brightness
    But even though I am giving the value 10, it only inputs a 3.

    Also, sometimes the FN keys for brightness and to disable the touchpad get confused, Instead of turning the brightness up/down, it disables the touchpad, but I can live with that.

    In the other thread he mentions to add asus-nb-wmi to /etc/modules I am not sure if he means to add a file named asus-nb-wmi or what specifics, but I have asked in the other thread.

    Hopefully this will get fixed with future kernels

    Thanks

  9. #8
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by jgezau View Post
    In the other thread he mentions to add asus-nb-wmi to /etc/modules I am not sure if he means to add a file named asus-nb-wmi or what specifics, but I have asked in the other thread.
    in Fedora 18, i think you need to use this dir:
    Code:
    /etc/modules-load.d/
    in it, put a file called:
    Code:
    asus-nb-wmi.conf
    the important part is the ".conf". you can make the first part anything you want. in that file, on a single line, put the name of the kernel driver (less the ".ko" extension):
    Code:
    asus-nb-wmi
    and save and quit the file.

    in the old days, you had to run:
    Code:
    depmod -a
    to update the file with kernel driver loading dependencies:
    Code:
    /lib/modules/`uname -r`/modules.dep
    but i don't think you need to do that anymore (doesn't hurt, though). then reboot, and see if it auto-loaded.

    for more details, run this command:
    Code:
    man modules-load.d

  10. #9
    Just Joined!
    Join Date
    Jan 2013
    Posts
    47
    Thank you so much. Is working perfectly now, like it used to

    The fn keys work correctly also, for keyboard backlight and to diasble/enable touchpad.

    Creating the file in
    Code:
    /etc/modules-load.d/
    did not work after rebooting the laptop, so I re did everything and created the file in
    Code:
    /etc/modprobe.d/
    and worked perfectly after rebooting the laptop, but I still left a copy of the file in moduled-load.d
    Last edited by jgezau; 05-26-2013 at 09:24 PM.

  11. #10
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by jgezau View Post
    Is working perfectly now, like it used to
    excellent! i'll go ahead and mark this as Solved for you. You can do this yourself using the Thread Tools link at the top of the page.

    Creating the file in
    Code:
    /etc/modules-load.d/
    did not work after rebooting the laptop, so I re did everything and created the file in
    Code:
    /etc/modprobe.d/
    and worked perfectly after rebooting the laptop, but I still left a copy of the file in moduled-load.d
    the modprobe.d dir is the directory that I've always used, too. interesting that the new modules-load.d dir doesn't work. that seems to be the new way to do it (not that i've used it). thanks for posting your solution, though!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •