Find the answer to your Linux question:
Results 1 to 3 of 3
I am using Redhat 2.6.18-92.el5. Every time when I login to this box as user oracle, I see error: -bash: ulimit: open files: cannot modify limit: Operation not permitted This ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    glu
    glu is offline
    Just Joined!
    Join Date
    Feb 2010
    Posts
    3

    Error: -bash: ulimit: open files: cannot modify limit: Operation not p


    I am using Redhat 2.6.18-92.el5. Every time when I login to this box as user oracle, I see error:
    -bash: ulimit: open files: cannot modify limit: Operation not permitted

    This appears to be due to the code in /etc/profile
    if [ $SHELL = "/bin/ksh" ]; then
    ulimit -p 16384
    ulimit -n 65536
    else
    ulimit -u 16384 -n 65536
    fi

    I checked the limit:
    $ ulimit -n
    1024
    $ ulimit -n 65636
    -bash: ulimit: open files: cannot modify limit: Operation not permitted

    I can change the limit down, say ulimit -n 1020, but can not change it up.

    The file /etc/security/limits.conf has
    oracle soft nofile 131072
    oracle hard nofile 131072
    oracle soft nproc 131072
    oracle hard nproc 131072
    oracle soft core unlimited
    oracle hard core unlimited
    oracle soft memlock 50000000
    oracle hard memlock 50000000

    What I should do to allow oracle user to have high open file limit?

    Thanks.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,380
    You need to login as root and modify the settings in /etc/security/limits.conf for user oracle.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    glu
    glu is offline
    Just Joined!
    Join Date
    Feb 2010
    Posts
    3
    Quote Originally Posted by Rubberman View Post
    You need to login as root and modify the settings in /etc/security/limits.conf for user oracle.
    Logged as root, and opened the file /etc/security/limits.conf. But what to be changed. I have already
    oracle soft nofile 131072
    oracle hard nofile 131072

    The thing is that as root I can do "ulimit -n 65536" but as oracle I cannot.

    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •