Find the answer to your Linux question:
Results 1 to 8 of 8
I have installed Centos 6.4 on my HP Pavillion G6, but after I installed two VM (Centos 6.4 and Ubuntu 12.04) onto Centos using kvm, the maximum resolution I can ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2013
    Posts
    32

    Unhappy I can't adjust screen resolution of virtual machine on Centos 6.4 host


    I have installed Centos 6.4 on my HP Pavillion G6, but after I installed two VM (Centos 6.4 and Ubuntu 12.04) onto Centos using kvm, the maximum resolution I can get is 1024x768 (please look at the screen capture, the black bars on both sides are ugly), the HP laptop has AMD GPU, which is not the most powerful one on the market, but sufficient for resolution such as 1368x768.

    I can't find Xorg.conf file in /etc/X11 or anywhere else, when I opened the details of the VM, I see there are several options, model: vga/cirrus/vmvga/xen, also notice that the RAM is 9 MB, but that is more than enough for 1368x768. I searched online forums, other people had similar issues, but no resolution. kvm.jpgvideo.jpg

  2. #2
    Just Joined!
    Join Date
    Jun 2013
    Posts
    32
    No one has any answer?

  3. #3
    Linux Engineer
    Join Date
    Apr 2012
    Location
    Virginia, USA
    Posts
    889

  4. #4
    Just Joined!
    Join Date
    Jun 2013
    Posts
    32

    Angry

    Quote Originally Posted by mizzle View Post
    Thanks, this is what I got when I ran the first one, similar issue when I ran the 2nd one:

    ************************************************** ********************
    ./13557-001.bin: line 1: ---: command not found
    ./13557-001.bin: line 2: +++: command not found
    ./13557-001.bin: line 3: @@: command not found
    ./13557-001.bin: line 4: /bin: is a directory
    ./13557-001.bin: line 7: -#define: command not found
    ./13557-001.bin: line 8: -#define: command not found
    ./13557-001.bin: line 9: +#define: command not found
    ./13557-001.bin: line 10: +#define: command not found
    ./13557-001.bin: line 14: ---: command not found
    ./13557-001.bin: line 15: +++: command not found
    ./13557-001.bin: line 16: @@: command not found
    ./13557-001.bin: line 17: long: command not found
    ./13557-001.bin: line 18: vga_draw_line_func: command not found
    ./13557-001.bin: line 19: /bin: is a directory
    ./13557-001.bin: line 20: syntax error near unexpected token `('
    ./13557-001.bin: line 20: `-#define VGA_BITMAP_SIZE ((8*1024*1024) / 4096 / 8 / sizeof(long))'
    ************************************************** **********************

  5. #5
    Linux Engineer
    Join Date
    Apr 2012
    Location
    Virginia, USA
    Posts
    889
    Ran the first what?

  6. #6
    Just Joined!
    Join Date
    Jun 2013
    Posts
    32

    Angry

    Quote Originally Posted by mizzle View Post
    Ran the first what?
    I attempted to use vga, not working, also tried others, not working, then I used this website:
    VBEMP NT Project - Universal VESA/VBE Video Display Driver

    and downloaded the *.bin files, tried and still not working!

  7. #7
    Linux Engineer
    Join Date
    Apr 2012
    Location
    Virginia, USA
    Posts
    889
    Did you start the VM via the command line with the appropriate switch as suggested by the article I linked?

  8. #8
    Just Joined!
    Join Date
    Jun 2013
    Posts
    32
    I can't comprehend that, what command? "virsh start"? That explanation is not easy to understand and I am researching this now


    here is what I get
    [root@smtp ~]# virsh dumpxml virtCentos | grep --color vga
    <model type='vga' vram='9216' heads='1'/>

    is this what you mean? so far it has not worked! the website you gave has poor explanation!
    Last edited by shfyang; 06-24-2013 at 09:59 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •