Find the answer to your Linux question:
Results 1 to 3 of 3
Looking for help (naturally) on something that has not been a problem in Solaris or Slack... however this is my first step into RedHat. CD/DVD ROM is identified as in ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2013
    Posts
    2

    CD/DVD will not mount (RedHat 5.1)


    Looking for help (naturally) on something that has not been a problem in Solaris or Slack... however this is my first step into RedHat.

    CD/DVD ROM is identified as in /dev
    lrwxrwxrwx 1 root root 4 Apr 21 2010 cdrom -> scd0
    lrwxrwxrwx 1 root root 4 Apr 21 2010 cdrom-sr0 -> scd0
    lrwxrwxrwx 1 root root 4 Apr 21 2010 dvd -> scd0
    lrwxrwxrwx 1 root root 4 Apr 21 2010 dvd-sr0 -> scd0

    /mnt lists:
    drwxr-xr-x 2 root root 4096 Jan 5 2010 cdrom
    drwxr-xr-x 2 root root 4096 Jan 5 2010 usbstick

    I placed a DVD in the drive and ran:

    [root_encrypt mnt]# mount -t iso9660 /dev/scd0 /mnt/cdrom

    to receive:

    mount: block device /dev/scd0 is write-protected, mounting read-only
    mount: wrong fs type, bad option, bad superblock on /dev/scd0,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so


    Without a DVD in the drive, it just fails miserable...

    Am I just out to lunch on this? I'd still rate myself as *green* in the linux world, so any help would be much appreciated.

    Thanks!

  2. #2
    Just Joined!
    Join Date
    Jul 2008
    Posts
    93
    Silly question: does the directory /mnt/cdrom exist?

    You can get rid of the "write protected" message by specifying read-only.
    Code:
    mount -o ro -t iso9660 /dev/scd0 /mnt/cdrom
    Other comment: maybe the DVD is not really an iso9660 file system. Some recent Linux distributions do funny things with the file system to try to cope with the Microsoft-inspired Secure Boot.

  3. #3
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,512
    Actually, a CD/DVD should automount in RHEL 5.x. It may be in /cdrom or /dvdrom for the mount point. If it doesn't automount, then you can mount it to some mount point (empty directory that you created), such as /mnt/cdrom or /mnt/dvdrom. There are also options to set in /etc/fstab so that it will be automounted in a standard location of your preference. In any case, you should skip the -t iso9660 option to the mount command - otherwise the command seems ok, other than that the /dev entry (/dev/scd0) may be incorrect.. The mount command should detect the file system type automatically. As for having no dvd in the drive, how can you expect it to succeed?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •