Find the answer to your Linux question:
Results 1 to 2 of 2
I'm extremely new to Linux, and I'm trying to figure out a system by which a user can change their password. I have no GUI; I'm using only the command ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2013
    Posts
    1

    "Authentication token manipulation error" when a user changes password


    I'm extremely new to Linux, and I'm trying to figure out a system by which a user can change their password. I have no GUI; I'm using only the command line. I've seen over a dozen different threads on this around the internet, but no one seems to have the exact same error context as I do, and none of the fixes I found solved the problem. Hopefully the community here can help.

    Code:
    Mycomputer login: user1
    Password:
    Last login: Mon Jul  1 17:05:18 on ttyl
    [user1(at)Mycomputer ~]$ su
    Password:
    [root(at)Mycomputer user1]# passwd user1
    New password:
    Retype new password:
    passwd: all authentication tokens updated successfully.
    [root(at)Mycomputer user1]# exit
    exit
    [user1(at)Mycomputer ~]$ passwd
    Changing password for user user1.
    Changing password for user1.
    (current) UNIX password:
    New password:
    Retype new password:
    passwd: Authentication token manipulation error
    I've tried remounting / , changing the permissions on the /etc/shadow and /etc/shadow- files, and doing it with a different user (user2). The (at)s are "at" signs, which the forum has a problem with me posting, even when "Automatically parse links in text" is disabled.

  2. #2
    Linux Newbie
    Join Date
    Jan 2013
    Location
    Argentina
    Posts
    120
    Thank you for writing seri, and welcome to the forums. In order to fix the situation, you would need to login as root, then enter:

    Code:
    passwd user1
    It will ask you for the password, change it accordingly and then reboot. It should work. However, if you had an encrypted home folder, system might still forbid you to get into graphical mode. I do not know how to fix it as I've actually replaced Ubuntu (where I had the problem because of a user password changing) with Fedora.

    I do not know if there is a permanent fix for that. What I did was login with (in your example user1) and then it asked me to enter a commadnd to allow its access.

    I hope I've helped. =)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •