Find the answer to your Linux question:
Results 1 to 6 of 6
Hello, I just upgraded from fedora 17 to fedora 19 and as well upgraded my cinnamon to 1.8 Because cinnamon has dropped the use of GNOME to change the desktop, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2012
    Posts
    15

    Changing wallpaper via script with latest version of cinnamon


    Hello, I just upgraded from fedora 17 to fedora 19 and as well upgraded my cinnamon to 1.8

    Because cinnamon has dropped the use of GNOME to change the desktop, Im wondering if anyone here knows what has replaced it? I had a script that would change my desktop background using gsettings:

    gsettings set org.gnome.desktop.background

    However this no longer works with cinnamon 1.8 Does anyone know how to change the background via terminal?

    Thanks

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    hi,

    i don't have cinnamon currently installed, so can't test it, but does the discussion here on LinuxMint's Cinnamon github site apply to your situation? One poster makes mention of gsettings and there seems to be a change in the background directory structure.

  3. #3
    Linux Enthusiast
    Join Date
    Dec 2011
    Location
    Turtle Island West
    Posts
    525
    This might work for you:

    chbg -once -mode maximize ~/gfx/wallpaper.jpeg

    for example. 'man chbg' will show you the ton of options it has. It can run once or hang around and keep changing the background every 30 seconds if that's your style.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Nov 2012
    Posts
    15
    Well I tried your command and chbg is not a valid command. What package do I need to install? I did a yum search for chbg but nothing came up.
    I have also created a bug report on github about my background problem so maybe the devs know the solution.

  6. #5
    Just Joined!
    Join Date
    Nov 2012
    Posts
    15
    I found the solution. For fedora 19 they changed the command to the following:

    Code:
    gsettings set org.cinnamon.background
    This made my script work wonderfully

  7. #6
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    excellent! glad you got it sorted, and thanks for posting your solution.

    marking as Solved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •