Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
Hello, I have just started using Fedora and encountered a problem I cannot solve even after some serious googling and I feel like a complete noob, which I probably am ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2013
    Posts
    14

    PoL not working/ Nvidia driver installation?


    Hello,
    I have just started using Fedora and encountered a problem I cannot solve even after some serious googling and I feel like a complete noob, which I probably am I will try to explain my situation the best I can.

    I am using a new Lenovo IdeaPad Y510p (i7-4700MQ, 8GB RAM, Dual NVIDIA GeForce GT 750M 2GB). It came with Windows 8, I disabled UEFI and istalled Fedora 19 (64bit) successfully without any issue. However, after updating from Software updater and a reboot the system failed to boot (there was a kernel update and also a nouveau driver for nvidia). I couldn't make Fedora boot, not even to recovery mode. So I reinstalled the system and have not updated these packages, as I do not know why updates brought Fedora down. Everything worked fine.

    I wanted to play World of Tanks, so I installed PlayOnLinux and it installed all the Wine dependencies (at least I think). I downloaded WoT and the client started normally, but after pressing 'play' the system hung and logged me out. After logging back I started PlayOnLinux and it displayed me an error message:

    PlayOnLinux is unable to find 32bits OpenGL libraries. You might encounter problem with your games.

    I thought this might be the problem (WoT logged me out of Fedora again), so I tried to find the solution. Some pages suggested to install new drivers for nvidia graphics. However, after trying one of the manuals (different nouveau drivers) I could not boot into Fedora again and the boot screen (until the fail) was much more ugly than before. I could find no other solution (as I am a complete noob), but to reinstall the system again
    I have tried another suggestion (installing 32bit libs by terminal, I only copied the command) and it said that the package was already installed. I think that PoL is unable to detect and use them.

    I found the driver (Linux AMD64/EM64T Display driver, version 319.49) on official nvidia site, but have not installed it. I am afraid of the problems with drivers I had and do not want to reinstall the system again (and I have also no idea how to do it, since the file opens in gedit EDIT: I did not make the file executable, that was why; but I am still too afraid to run it). And I am not even sure if it will help.

    Can someone please instruct me step-by-step how to solve the problem with PoL libraries? Do I need to update the kernel or drivers (if yes, how to do it and do not screw up the system as I did it?)
    Last edited by Adalee; 08-23-2013 at 09:26 AM.

  2. #2
    Linux Newbie
    Join Date
    Nov 2009
    Posts
    225
    Sorry. Not being a Fedora user (Suse since 3.5), I can't give you step by step but I hope I can give you an overall clue.

    With an nvidia card, I *always* install the proprietary nvidia driver (despite the fact that it taints the kernel). I will continue to do so until the nouveau driver is up to snuff.

    Things you need to be very aware of. The nvidia drivers are built against the specific kernel that was there. That is, when you download the driver pack and run it (at run level 3 - no x-server), it builds against the kernel that was running at that time. Should the kernel change (update or w.h.y.) you will need to rebuild the driver.

    With the driver will come all the GL modules you need. Also, you will have a couple of nvidia utilities called nvidia-SOMETHING. "settings" allows you to configure your desktop, "uninstall" will remove the driver and all its files and "xconfig" (I think) allows you to configure X.

    Blacklist the nouveau driver (/etc/modprobe.d/50-blacklist ?) before you boot your system.

    If you still get no luck. Try using either or both boot options "nomodeset" & "nopat". Your box sounds too new to need these but you never know.

    I wish you well and will monitor the thread but hopefully a Fedora guru can be of more help.

    Cheers - VP

  3. #3
    Just Joined!
    Join Date
    May 2013
    Posts
    14
    Thanks a lot for reply!

    So basicaly, when I firstly needed to reinstall the system, it was caused by nouveau update and not kernel? Is the kernel update "safe" for me, or should I rather not touch it? If yes, then do I need to install the nvidia drivers after or before the update?

    The default runlevel for Fedora is 5 (at least I have it there and I didn't modified anything), I hope it is not an issue.

    However, in my /etc/modprobe.d I have only openfwwf.conf file, no blacklist. I am not able to find the blacklist via terminal (find blacklist - no such file or directory (is it even a good command?)). The only installed drivers I found via Software installer (search for nouveau) are xorg-x11-drv-nouveau-1:1.0.7-1fc19 (64bit); then aren't there any other installed on my system? How can I blacklist them, or would it be enough to uninstall them?

    Thanks a lot one more time.
    Last edited by Adalee; 08-23-2013 at 10:48 AM.

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,633
    1. Black list the nouveau drivers
    2. Install the current proprietary nVidia drivers (available from their web site).
    3. Have fun!
    4. The black list file is found as /etc/modprobe.d/blacklist.conf - add this line "blacklist nouveau" and reboot into runlevel 3 to install the nVidia driver.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  5. #5
    Just Joined!
    Join Date
    May 2013
    Posts
    14
    Quote Originally Posted by Rubberman View Post
    1. Black list the nouveau drivers
    2. Install the current proprietary nVidia drivers (available from their web site).
    3. Have fun!
    4. The black list file is found as /etc/modprobe.d/blacklist.conf - add this line "blacklist nouveau" and reboot into runlevel 3 to install the nVidia driver.
    I have downloaded the proprietary drivers, but I still don't have any blacklist file in modprobe.d - as I stated before, ther is only openwwf.conf file. Blacklist is not even a hidden file.

  6. #6
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,633
    Quote Originally Posted by Adalee View Post
    I have downloaded the proprietary drivers, but I still don't have any blacklist file in modprobe.d - as I stated before, ther is only openwwf.conf file. Blacklist is not even a hidden file.
    It's possible they moved the file in current fedora versions. See if the command (run as root) "find /etc -iname 'blacklist.conf'" shows anything. You should see one in /etc/yum/pluginconf.d (not the one you want). If a likely candidate doesn't appear, then you can create blacklist.conf in /etc/modprobe.d and add the line "blacklist nouveau" to the file. Reboot into runlevel 3 and try to install the nVidia driver and OpenGL components (an option during the installation).

    After you install the driver (assuming it succeeds), then run the command "startx" from the command line to verify it was installed successfully. Assuming that works, reboot into runlevel 5.

    One last thing is that you might look in /etc for the file modprobe.conf. That is an alternative location for blacklisting drivers.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  7. #7
    Just Joined!
    Join Date
    May 2013
    Posts
    14
    See if the command (run as root) "find /etc -iname 'blacklist.conf'" shows anything. You should see one in /etc/yum/pluginconf.d (not the one you want).
    you might look in /etc for the file modprobe.conf. That is an alternative location for blacklisting drivers.
    Only the file in /etc/yum/pluginconf.d showed up and I have no modprobe.conf file.
    So, to make it clear to me:
    1. I create blacklist.conf eg in gedit. In the file will be the line "blacklist nouveau".
    2. I change to runlevel 3 with a command "init 3" Or is the command with Fedora 19 different?
    3. I have the driver with name "NVIDIA-Linux-x86_64-319.49.run" in my Downloads file. I have made the file executable. So, I run the file from terminal with simply typing its name and it installs everything I need.
    4. I run "startx". BTW, what to do if it doesn't work?
    5. Change to runlevel 5 with "init 5" Or again, just to make sure, is this the right command?

    Thanks for the help and please, correct me if I have wrote something stupid or bad.

  8. #8
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,633
    Quote Originally Posted by Adalee View Post
    Only the file in /etc/yum/pluginconf.d showed up and I have no modprobe.conf file.
    So, to make it clear to me:
    1. I create blacklist.conf eg in gedit. In the file will be the line "blacklist nouveau".
    correct
    2. I change to runlevel 3 with a command "init 3" Or is the command with Fedora 19 different?
    Use either "init 3" or "telinit 3"
    3. I have the driver with name "NVIDIA-Linux-x86_64-319.49.run" in my Downloads file. I have made the file executable. So, I run the file from terminal with simply typing its name and it installs everything I need.
    Depending upon your PATH variable, you may need to use "./NVIDIA-Linux-x86_64-319.49.run" instead since if "." is not in your PATH, it won't find it.
    4. I run "startx". BTW, what to do if it doesn't work?
    Post the output (errors) here.
    5. Change to runlevel 5 with "init 5" Or again, just to make sure, is this the right command?
    Again, either "init 5" or alternatively "telinit 5". Myself, I prefer telinit. It is the command intended to modify the run level after the system has been started.

    Thanks for the help and please, correct me if I have wrote something stupid or bad.
    There are no stupid questions - only stupid answers!
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  9. #9
    Just Joined!
    Join Date
    May 2013
    Posts
    14
    Thanks a lot!
    However, the nvidia installer told me that I need to disable current nouveau driver in my modprobe.d file (but I have created it). It asked me if I want it to create the file itself, so I chose yes. After that it has finaly realised that I have written the blacklist.conf file and I got the message which said that there was another disabling file. The installator probably didn't know what to do, but failed. After I got back to runlevel 5, I checked the modprobe.d and there was also the file (called "nvidia-installer-disable-nouveau.conf") generated by installer:

    # generated by nvidia-installer
    blacklist nouveau
    options nouveau modeset=0
    Should I delete my blacklist.conf file and leave there the one by installer?

    EDIT: What if I upgrade my kernel? I have not done it, but it is available in repositories and (read my first post) I am not sure if it will be working.

  10. #10
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,633
    I don't think that having multiple blacklists is a problem. Is this the latest Fedora version? If so, it may be a Fedora issue that should be reported to them. You can try a kernel update, but I'm not sure it will help. In the past, I have deliberately reconfigured and rebuilt the kernel without nouveau support, which worked, but since it was a custom kernel, it made me rebuild the kernel when I wanted to install a new one...
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •