Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    PyYAML installation failed


    Hi,
    when I installed PyYAML, it failed on dependency of libyaml. but I have already installed libyaml and I can see the libyaml-0.so.2 in the path. I am not sure what I need to do next. Please help.

    # yum install python27-PyYAML.x86_64
    Loaded plugins: refresh-packagekit, security
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package python27-PyYAML.x86_64 0:3.10-4.el6 will be installed
    --> Processing Dependency: libyaml-0.so.2()(64bit) for package: python27-PyYAML-3.10-4.el6.x86_64
    --> Finished Dependency Resolution
    Error: Package: python27-PyYAML-3.10-4.el6.x86_64
    Requires: libyaml-0.so.2()(64bit)

    But here I got libyaml already:
    # ldconfig -p | grep libyaml
    libyaml-0.so.2 (libc6,x86-64) => /usr/local/lib/libyaml-0.so.2
    libyaml-0.so.2 (libc6,x86-64) => /lib64/libyaml-0.so.2


    Thanks,
    Colin

  2. #2
    hi, have you enabled extra repositories that might have a copy of pyYAML in it? if its included in the main repositories then disable the repositories you've added and then try again. it might not be the problem but is worth a try . also the package might be looking in a different location for your library.

  3. #3
    also worst comes to worst try to install it from source PyYAML ? PyYAML

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •