Find the answer to your Linux question:
Results 1 to 4 of 4
I have 3 centos 6.2 servers which will not go online. Recently i have setup a centos 6.4 server which will go online and I have setup yum repo in ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2013
    Posts
    32

    YUm error


    I have 3 centos 6.2 servers which will not go online. Recently i have setup a centos 6.4 server which will go online and I have setup yum repo in that
    When I gave update command(in 6.2 server) it gave the following error.

    Error: Package: curl-7.19.7-37.el6_4.x86_64 (base)
    Requires: libcurl = 7.19.7-37.el6_4
    Removing: libcurl-7.19.7-26.el6_1.2.x86_64 (@anaconda-CentOS-201112091719.x86_64/6.2)
    libcurl = 7.19.7-26.el6_1.2
    Updated By: libcurl-7.19.7-35.el6.x86_64 (base)
    libcurl = 7.19.7-35.el6
    Error: Package: e2fsprogs-1.41.12-14.el6_4.2.x86_64 (base)
    Requires: libss = 1.41.12-14.el6_4.2
    Removing: libss-1.41.12-11.el6.x86_64 (@anaconda-CentOS-201112091719.x86_64/6.2)
    libss = 1.41.12-11.el6
    Updated By: libss-1.41.12-14.el6.x86_64 (base)
    libss = 1.41.12-14.el6
    Error: Package: e2fsprogs-1.41.12-14.el6_4.2.x86_64 (base)
    Requires: libcom_err = 1.41.12-14.el6_4.2
    Removing: libcom_err-1.41.12-11.el6.i686 (@yum)
    libcom_err = 1.41.12-11.el6
    Updated By: libcom_err-1.41.12-14.el6.i686 (base)
    libcom_err = 1.41.12-14.el6
    Error: Package: ntsysv-1.3.49.3-2.el6.x86_64 (base)
    Requires: chkconfig = 1.3.49.3-2.el6
    Removing: chkconfig-1.3.47-1.el6.x86_64 (@anaconda-CentOS-201112091719.x86_64/6.2)
    chkconfig = 1.3.47-1.el6
    Updated By: chkconfig-1.3.49.3-2.el6_4.1.x86_64 (base)
    chkconfig = 1.3.49.3-2.el6_4.1
    Available: chkconfig-1.3.49.3-2.el6.x86_64 (base)
    chkconfig = 1.3.49.3-2.el6
    Error: Package: e2fsprogs-libs-1.41.12-14.el6_4.2.x86_64 (base)
    Requires: libcom_err = 1.41.12-14.el6_4.2
    Removing: libcom_err-1.41.12-11.el6.i686 (@yum)
    libcom_err = 1.41.12-11.el6
    Updated By: libcom_err-1.41.12-14.el6.i686 (base)
    libcom_err = 1.41.12-14.el6

    You could try using –skip-broken to work around the problem
    You could try running: rpm -Va –nofiles –nodigest

    How to fix this, Any inputs will be helpful.

  2. #2
    Just Joined!
    Join Date
    Aug 2013
    Posts
    36
    hsve you added any extra repositories like epel or ? i used to get an error that said "You could try using –skip-broken to work around the problem" so i disabled my extra repos i installed and the errors went away. i cant remember what the repo i had problems with was. it was somethingrepo... its worth a try

  3. #3
    Just Joined!
    Join Date
    Jan 2013
    Posts
    32
    I have not enabled epel repo, with --skip-broken i have updated the server(test). I want to will it affect the updation or corrupt. I have done it in test server and its working fine. Now the same has to be done in production.

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,530
    Running yum with --skip-broken won't hurt anything. I use it all the time since there are some packages that need to be updated but can't because they need newer versions of others that are in turn needed by other packages in their current release level... Sometimes, I can work around that by disabling some repos. You can do that either by setting the enable=0 flag in the repo file, or simply by adding the --disablerepo=reponame on the command line for yum.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •