Find the answer to your Linux question:
Results 1 to 6 of 6
I just recently installed two new kernels and neither of them work, im working on my old kernel. when i boot in a new kernel it takes a long time ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2013
    Posts
    36

    rhel, booting new kernels causes screen to hang at title...


    I just recently installed two new kernels and neither of them work, im working on my old kernel. when i boot in a new kernel it takes a long time for it to load, and then it hangs at the screen that says in white letters "red hat enterprise linux 6". when i boot in with my oldest kernel i get a report that there is a problem with my kernel package. the problem is:
    irq 19: nobody cared (try booting with "irqpoll" option)
    any help would be great. if you know how to use the irqpoll option that would be great too. thanks!

  2. #2
    Just Joined!
    Join Date
    Feb 2007
    Posts
    98
    Hello sanducket,

    Could you post here, your /boot/grub/grub.conf file, I'm interested in knowing the kernel parameters. Are you able to boot into single user in any of your kernels?

    In regards to your irq 19, that error could be related to the hardware, and it means that there may be some hardware that the kernel is not aware of. I'm not very familiar with that error, so I can't really say much on it, but google may be your best resource in regards to your irq 19 error.

  3. #3
    Just Joined!
    Join Date
    Aug 2013
    Posts
    36
    heres my grub.conf
    Code:
    default=0
    timeout=5
    splashimage=(hd0,0)/grub/splash.xpm.gz
    hiddenmenu
    title Red Hat Enterprise Linux Client (2.6.32-422.el6.i686)
    	root (hd0,0)
    	kernel /vmlinuz-2.6.32-422.el6.i686 ro root=/dev/mapper/vg_alan-lv_root rd_NO_LUKS rd_LVM_LV=vg_alan/lv_root rd_NO_MD SYSFONT=latarcyrheb-sun16  KEYBOARDTYPE=pc KEYTABLE=us rd_LVM_LV=vg_alan/lv_swap rd_NO_DM LANG=en_US.UTF-8 rhgb quiet crashkernel=auto
    	initrd /initramfs-2.6.32-422.el6.i686.img
    title Red Hat Enterprise Linux Client (2.6.32-419.el6.i686)
    	root (hd0,0)
    	kernel /vmlinuz-2.6.32-419.el6.i686 ro root=/dev/mapper/vg_alan-lv_root rd_NO_LUKS rd_LVM_LV=vg_alan/lv_root rd_NO_MD SYSFONT=latarcyrheb-sun16  KEYBOARDTYPE=pc KEYTABLE=us rd_LVM_LV=vg_alan/lv_swap rd_NO_DM LANG=en_US.UTF-8 rhgb quiet crashkernel=auto
    	initrd /initramfs-2.6.32-419.el6.i686.img
    title Red Hat Enterprise Linux Client (2.6.32-358.18.1.el6.i686)
    	root (hd0,0)
    	kernel /vmlinuz-2.6.32-358.18.1.el6.i686 ro root=/dev/mapper/vg_alan-lv_root rd_NO_LUKS rd_LVM_LV=vg_alan/lv_root rd_NO_MD SYSFONT=latarcyrheb-sun16  KEYBOARDTYPE=pc KEYTABLE=us rd_LVM_LV=vg_alan/lv_swap rd_NO_DM LANG=en_US.UTF-8 rhgb quiet crashkernel=auto
    	initrd /initramfs-2.6.32-358.18.1.el6.i686.img
    ill try different runlevels and get back to you

  4. #4
    Just Joined!
    Join Date
    Aug 2013
    Posts
    36
    runlevel 1/single user causes the same problem. the computer hangs

  5. #5
    Just Joined!
    Join Date
    Feb 2007
    Posts
    98
    Do any of your kernel works? Because you have mentioned you're getting an irq 19 error when you boot the old one, so I'm not sure, but maybe it could be hardware since not even the old kernel works.

    My suggestion at this point, would be for you to play around with some of the kernel settings and see if any would work. For starters, I would remove "crashkernel=auto" from the kernel and try rebooting without it to see if it works or you get a different error message (you can also add fastboot in there to skip fsck during boot up).

    If all fails, then I would suggest if at all possible that you try re-installing the kernel and see if it works.. Worst case scenario is that it's a hardware problem, and for that I would advise that do some search on that irq 19 error and see what you can do to get to the bottom of it.

  6. #6
    Just Joined!
    Join Date
    Aug 2013
    Posts
    36
    k will try removing crashkernel=auto. its not too big a deal though because my oldest kernel works. the report in the oldest kernel appears in the bug report it doesnt seem to affedt anything though. ive filed a nug report so maybe redhat will fix it in their next kernel update. its funny though, i had this problem on my 64 bit computer then i logged in on an old kernel and installed the new kernel and that one works fine, did the same thing on my 32 bit and im getting the error still, strange...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •