Find the answer to your Linux question:
Results 1 to 2 of 2
Hi I am using TightVNC view from Window7 to connect to Centos 6.4 desktop. I got the error "Error in tightVNC viewer no connection could be made because the target ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Posts
    45

    TightVNC viewer


    Hi

    I am using TightVNC view from Window7 to connect to Centos 6.4 desktop. I got the error "Error in tightVNC viewer no connection could be made because the target machine actively refused it. I an ssh to the machine using the same ip address. If I turn off the firewall, I can vnc to the centos box. Any help?
    Thanks.

    Best regards,

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,882
    Is that the CentOS firewall that you're turning off? A firewall somewhere is blocking connections to your VNC screen, so you need to open the VNC ports using the firewall's configuration tools.

    The port that needs to be open is 5900 + screen number (so, for example, if you're on screen :1, that'll be 5901). If you don't know which screen number you're running on, then you could just open 5900 to 5905.

    If your Linux box is plugged into the Internet, it might not be wise to open this port - it would mean anyone can connect and attempt to guess your vnc password. As SSH is functional, you'd be better off using that and forwarding the remote port 590X to your local machine, and then connecting your VNC client to the localhost + screen number. If you're using putty to connect from Windwos, then there is a setting in the SSH config to do the remote port forward.
    Linux user #126863 - see http://linuxcounter.net/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •