Find the answer to your Linux question:
Results 1 to 9 of 9
Hi I have been running Redhat 5.4 with oracle 11g. Recently I started getting alerts for / directory running out of space. I never had this issue since last 3 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2013
    Posts
    5

    IOC* and SSS* files under tmp directory


    Hi

    I have been running Redhat 5.4 with oracle 11g. Recently I started getting alerts for / directory running out of space. I never had this issue since last 3 years. So I looked at the server to see whats changed. I noticed some random files getting created in /tmp directory and all these files begin with SSS and IOC. Has anyone come across these files. I usually delete them to release space but not sure which process or application is creating these files. Not sure if they get created by oracle. Is there any way I can find out what is it creating or anyone knows about these files here?

    Many thanks
    N

  2. #2
    Linux Newbie
    Join Date
    Nov 2009
    Posts
    214
    Do you mean that the files have the extension IOC and SSS?

    I've only heard about IOC extensions in the context of winamp but...

    Have you googled for any info? I know there is at least one site where they document what software uses what files.

  3. #3
    Just Joined!
    Join Date
    Nov 2013
    Posts
    5
    Hi Voidpointer69

    Thanks for your reply. Yes I have googled and haven't found a single documentation regarding such files. They are not the extensions. There are files in tmp directory like SSSxythx SSSthyxv IOCjdgtyh IOCbbdhut etc. Is there any way to find out which program created those files or any kind of monitoring i can setup on tmp directory?

  4. #4
    Linux Newbie
    Join Date
    Nov 2009
    Posts
    214
    Hmmm....

    What user created them? Try something like lsof | egrep SSS (or IOC) and see if they show up.

    What does file SSSxythx say? "Data"? Can you get any clues from hexdump -C SSSxythx?

    Look at the time stamps on the files. If they extend across days, you could run a script to delete those from the past.

  5. #5
    Just Joined!
    Join Date
    Nov 2013
    Posts
    5
    Tried lsof | egrep SSS (or IOC) nothing showed up.

    Data is just binary. When I run hexdump -C SSSMzGPhW, i get result (18-11-2013 14-34-06.jpg)

    Check the time stamp in this screenshot 18-11-2013 14-37-50.jpg

    I am not sure if these files are created by ORACLE text index.

    I am so stuck with this problem.

    Thanks for your help on this.

  6. #6
    Linux Newbie
    Join Date
    Nov 2009
    Posts
    214
    Sorry, those pics are too dark for me to see anything.

  7. #7
    Just Joined!
    Join Date
    Nov 2013
    Posts
    5
    03-12-2013 17-48-45.jpg Can you see now. There is no option here to attach file. I guess when I insert it compresses. Hope you can see now.

    Aaah found the attachment option. Just attached the screenshot.

    Thanks

  8. #8
    Linux Newbie
    Join Date
    Nov 2009
    Posts
    214
    Sorry. No, no better I'm afraid.

    What user created these files?

  9. #9
    Just Joined!
    Join Date
    Nov 2013
    Posts
    5
    Hi there

    You can close this ticket now as I have found what program is creating those files. It is oracle text index which uses tmp directory to process documents. It creates temp files and deletes once finished but sometimes files are not deleted. There's no official way of modifying the temp location for these files, but it could be achieved by replacing the ctxhx executable with a shell script wrapper which sets the value of TEMPDIR (or whateve env variable is used - you'll have to experiment) then calls the actual ctxhx executable. Something like:

    #!/bin/sh
    export TEMPDIR=/my/tmp
    $ORACLE_HOME/bin/ctxhx_original $1 $2 $3 $4 $5 $6 $7 $8 $9

    Thanks for your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •