Find the answer to your Linux question:
Results 1 to 3 of 3
hi! i am a noob in linux. i had worked on ubuntu before but recently moved to fedora 20. i have this package prozilla-2.0.4.tar.bz2 which i tried to install. when ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2013
    Posts
    1

    can't "make" after "./configure"


    hi! i am a noob in linux.

    i had worked on ubuntu before but recently moved to fedora 20.

    i have this package prozilla-2.0.4.tar.bz2 which i tried to install.

    when i did a ./configure

    i get this


    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking for style of include used by make... GNU
    checking for g++... no
    checking for c++... no
    checking for gpp... no
    checking for aCC... no
    checking for CC... no
    checking for cxx... no
    checking for cc++... no
    checking for cl... no
    checking for FCC... no
    checking for KCC... no
    checking for RCC... no
    checking for xlC_r... no
    checking for xlC... no
    checking for C++ compiler default output file name... configure: error: C++ compiler cannot create executables
    See `config.log' for more details.



    can't "make",probably because g++,c++,gpp,acc,cc,cxx,cc++,cl,FCC,KCC,RCC,xlC are not present?

    is it so? if yes,doi need to install these manually or is there something else wrong?

  2. #2
    Linux Guru
    Join Date
    Dec 2013
    Posts
    1,570
    You can start with 'yum install make automake gcc gcc-c++ kernel-devel'. That will get you started anyway.

  3. #3
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Location
    Harrow, UK
    Posts
    1,259
    A quicker way is to group install "development tools". This is the Fedora equivalent to the Debian/Ubuntu "build-essential" package.
    "I'm just a little old lady; don't try to dazzle me with jargon!"
    www.hrussman.entadsl.com

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •