Find the answer to your Linux question:
Results 1 to 3 of 3
I am running centos version 6.5 Code: [e@localhost ~]$ cat /etc/redhat-release CentOS release 6.5 (Final) My openssh is at version 5.3 Code: [e@localhost ~]$ ssh -v OpenSSH_5.3p1, OpenSSL 1.0.1e-fips 11 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2012
    Posts
    4

    Centos 6.5: Upgrade OpenSSH from 5.3 to > 5.6


    I am running centos version 6.5

    Code:
    [e@localhost ~]$ cat /etc/redhat-release 
    CentOS release 6.5 (Final)
    My openssh is at version 5.3

    Code:
    [e@localhost ~]$ ssh -v
    OpenSSH_5.3p1, OpenSSL 1.0.1e-fips 11 Feb 2013
    First off, is it possible that CentOS's version of OpenSSH 5.3 contains a patch for the control persist feature?

    I need a version of openssh greater than than 5.5 in order to use ControlPersist in my .ssh/config (correct?)

    Code:
    sudo yum update
    does not contain an update for OpenSSH. Is there an easy way to upgrade?

    I tried following this guide but I was getting a weird error with installing maria db when I tried to
    Code:
    sudo yum update
    after adding the centalt repo.

    Side question: is there a way to inline the code syntax? I am trying to have `sudo yum update` be shown as code inside of a sentence.

  2. #2
    Just Joined!
    Join Date
    Mar 2012
    Posts
    4
    Quote Originally Posted by dadoprso View Post
    I am running centos version 6.5

    Code:
    [e@localhost ~]$ cat /etc/redhat-release 
    CentOS release 6.5 (Final)
    My openssh is at version 5.3

    Code:
    [e@localhost ~]$ ssh -v
    OpenSSH_5.3p1, OpenSSL 1.0.1e-fips 11 Feb 2013
    First off, is it possible that CentOS's version of OpenSSH 5.3 contains a patch for the control persist feature?

    I need a version of openssh greater than than 5.5 in order to use ControlPersist in my .ssh/config (correct?)

    Code:
    sudo yum update
    does not contain an update for OpenSSH. Is there an easy way to upgrade?

    I tried following this guide but I was getting a weird error with installing maria db when I tried to
    Code:
    sudo yum update
    after adding the centalt repo.

    Side question: is there a way to inline the code syntax? I am trying to have `sudo yum update` be shown as code inside of a sentence.

    The CentALT repository has a dependecy of the EPEL repository. The readme says to manually create a repo file, however a bootstrap RPM is available.

    Steps

    Install EPEL repository , as this is a dependency
    Create a centalt repo file.
    # rpm -Uvh http://centos.alt.ru/repository/cent...6-1.noarch.rpm

  3. #3
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,755
    The most current CentOS 6.x version of the openssh package is 5.3p1-94. To upgrade beyond that you will need to install from source. Caveat user - newer versions may be incompatible with dependent stuff, so you may need to build/install into /usr/local instead of /usr with the default configure prefix of /usr/local. That will allow you to have both the default, and the new packages installed on your system, but programs that you want to use the new one will have to be started with the LD_LIBRARY_PATH environment set to /usr/local/lib or /usr/local/lib64.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •