Find the answer to your Linux question:
Results 1 to 9 of 9
A friend has asked me to get Fedora 20 (3.14.2-200.fc20.x86_64) onto his Samsung nc110 netbook which has a GMA500 graphics chip. The problem is that as soon as Kernel Mode ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    set
    set is offline
    Just Joined!
    Join Date
    May 2014
    Location
    England
    Posts
    6

    Display black straight after KMS on Fedora 20 with gma500_gfx


    A friend has asked me to get Fedora 20 (3.14.2-200.fc20.x86_64) onto his Samsung nc110 netbook which has a GMA500 graphics chip. The problem is that as soon as Kernel Mode Setting begins, there's no video thereafter until reboot. Nothing, just a dim backlight behind a black LCD screen. Access via SSH always works.

    I strongly suspect it's got something to do with KMS (though I might be wrong) because when booting from Arch 201405 install media (3.14.1-1-ARCH), display works fine every time, whereas the Fedora screen goes black at around the same point of kernel booting.

    With Fedora (disabling the Plymouth splash), the kernel dmesg output disappears right after the point where KMS should change mode, never to be seen again. An external DVI monitor (from HDMI out) always works, but still nothing on the internal LCD. In this state, the cursor can move to the side and get lost, indicating that X knows there are two displays side-by-side, though nothing shows on the screen. (Moreover, to further confuse matters, once every 10 or 15 reboots, it actually all displays as if no problem, with exact same boot parameters).

    Both Arch and Fedora load the same gma500_gfx and related modules (hope I haven't overlooked anything) as shown by lsmod. I've tried acpi=off (kernel panic). Tried xdriver=vesa (no difference). It doesn't matter whether it's x86 or x86_64 - same results.

    This article describes what I believe to be the same issue with a different netbook, but appears he/she hasn't tried disabling the splash screen like I did (boot parameters 'rhgb' and 'splash').
    ask.fedoraproject.org/en/question/44120/black-screen-on-fedora-20-right-after-grub/

    It's just bizarre because the other two distros I have tried (Arch, BBQ) will work no problem. BBQ Linux even boots straight into X fine every time. It's JUST FEDORA. I have only tried Fedora 20 (no earlier).

    I'm exhausted for ideas. Hope someone can advise me on setting Fedora 20 up to work right.

  2. #2
    Linux Engineer
    Join Date
    Apr 2012
    Location
    Virginia, USA
    Posts
    896
    I had a similar problem when installing Fedora 18. I don't think they ever addressed this bug. Try the steps at http://funwithlinux.net/2013/02/fedora-18-wont-boot/ to see if that works for you.

  3. #3
    set
    set is offline
    Just Joined!
    Join Date
    May 2014
    Location
    England
    Posts
    6
    Hi Mizzle, I appreciate your suggestion. I did try it anyway, using the GRUB console as described to solve their display problem, but their solution didn't work.

    I'm really sure it has something to do with Kernel Mode Switching... it's something the kernel is doing at the moment it changes resolution during boot, but someone might correct me.

    And I have found it's specific to when I try Fedora, as the Arch and BBQ media boot fine, and display continues to work after KMS.

    Anyone think it's worth asking in the kernel forum?

  4. #4
    Linux Engineer
    Join Date
    Apr 2012
    Location
    Virginia, USA
    Posts
    896
    Arch has good documentation, you can always count on them to provide some insight:
    Disabling modesetting

    You may want to disable KMS for various reasons, such as getting a blank screen or a "no signal" error from the display, when using the Catalyst driver, etc. To disable KMS add nomodeset as a kernel parameter. See Kernel parameters for more info.
    Along with nomodeset kernel parameter, for Intel graphics card you need to add i915.modeset=0 and for Nvidia graphics card you need to add nouveau.modeset=0. For Nvidia Optimus dual-graphics system, you need to add all the three kernel parameters (i.e. "nomodeset i915.modeset=0 nouveau.modeset=0").
    https://wiki.archlinux.org/index.php...l_mode_setting

    So, try adding nomodeset i915.modeset=0
    to your kernel arguments at boot.

  5. #5
    set
    set is offline
    Just Joined!
    Join Date
    May 2014
    Location
    England
    Posts
    6
    Mizzle, really appreciate that. I still haven't managed to solve it, but I did try it and I believe it is getting closer to the core of the problem!!! Very much appreciated.

    So I tried disabling KMS with nomodeset and i915.modeset=0 (as gma500 is intel graphics)... but screen still went black.

    Then tried both disabling KMS and disabling framebuffer with the above plus vga=normal nofb video=vesafb:off ... and still, it's like kernel is ignoring its boot arguments and taking instruction from somewhere else, because screen still goes blank.
    (got the framebuffer tip from kb.digium.com/articles/FAQ/How-to-disable-the-Linux-frame-buffer-if-it-s-causing-problems )

    But that's really close, mizzle, we almost got it solved.

  6. #6
    set
    set is offline
    Just Joined!
    Join Date
    May 2014
    Location
    England
    Posts
    6
    by the way, I gave those arguments at the grub prompt (pressed 'e' to edit the boot line) and passed those parameters on the line that begins 'linux'.

  7. #7
    Linux Engineer
    Join Date
    Apr 2012
    Location
    Virginia, USA
    Posts
    896
    Here are some other sites that might help: https://wiki.debian.org/KernelModese...Intel_GfxCards

    How to debug Xorg problems - FedoraProject

    Black screen
    According to this Debian wiki, CONFIG_FRAMEBUFFER_CONSOLE must be set to y (aka built-in). Otherwise, it is possible to always have a black screen unless nomodeset is passed to the kernel, thus disabling KMS.
    You can also try to pass acpi_osi="Linux" to the kernel line to try to solve this kind of issue
    from : intel - Gentoo Wiki

  8. #8
    set
    set is offline
    Just Joined!
    Join Date
    May 2014
    Location
    England
    Posts
    6
    again, Mizzle, thanks, but it's not actually Xorg that's the display problem.

    The simplest explanation is that the display 'dies' as soon as KMS begins. In Fedora 20, I have been unable to turn off KMS, and besides, other (Arch, BBQ) etc work fine after KMS with the gma500_gfx.

    It's actually KMS where the display dies... but only on Fedora 20. KMS works fine on other distros, but I can't find the exact point in Fedora 20 that I can compare with on Arch or BBQ.

  9. #9
    set
    set is offline
    Just Joined!
    Join Date
    May 2014
    Location
    England
    Posts
    6
    (but I do genuinely appreciate your help by the way).

    I'll try it anyway and come back to see if things improve.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •