Find the answer to your Linux question:
Results 1 to 2 of 2
Like Tree1Likes
  • 1 Post By gregm
Hi, I'm trying to compile an apache add on but I keep getting this compiler error, and I'm not sure what to do to fix it. Code: make all-recursive make[1]: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2014
    Posts
    1

    Question can't compile mod_authz_ldap, odd error


    Hi, I'm trying to compile an apache add on but I keep getting this compiler error, and I'm not sure what to do to fix it.


    Code:
    make  all-recursive
    make[1]: Entering directory `/home/sysassist/mod_authz_ldap-0.27'
    Making all in module
    make[2]: Entering directory `/home/sysassist/mod_authz_ldap-0.27/module'
    if /bin/sh ../libtool --mode=compile ` -q CC` -DHAVE_CONFIG_H -I. -I. -I..  -I` -q INCLUDEDIR` -I/include  -DAUTHZ_LDAP_HAVE_SSL ` -q CFLAGS` ` -q CFLAGS_SHLIB` -g -O2 -MT mod_authz_ldap_la-auth.lo -MD -MP -MF ".deps/mod_authz_ldap_la-auth.Tpo" \
    	  -c -o mod_authz_ldap_la-auth.lo `test -f 'auth.c' || echo './'`auth.c; \
    	then mv -f ".deps/mod_authz_ldap_la-auth.Tpo" ".deps/mod_authz_ldap_la-auth.Plo"; \
    	else rm -f ".deps/mod_authz_ldap_la-auth.Tpo"; exit 1; \
    	fi
    /bin/sh: -q: command not found
    /bin/sh: -q: command not found
    /bin/sh: -q: command not found
    /bin/sh: -q: command not found
    libtool: unrecognized option `-DHAVE_CONFIG_H'
    Try `libtool --help' for more information.
    make[2]: *** [mod_authz_ldap_la-auth.lo] Error 1
    make[2]: Leaving directory `/home/sysassist/mod_authz_ldap-0.27/module'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/sysassist/mod_authz_ldap-0.27'
    make: *** [all] Error 2

  2. #2
    Linux Engineer
    Join Date
    Dec 2013
    Posts
    1,188
    Note the line beginning: if /bin/sh ../libtool --mode=compile ` -q CC`

    The empty space before the -q is the problem. Something was supposed to expand to fill that space - likely the appropriate compiler. Did you run configure? Was it a clean run?
    Rubberman likes this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •