Find the answer to your Linux question:
Results 1 to 2 of 2
We use RPMS for our packaging and yum to update our environments. We have an rpm pacakge-5.1.1-3 installed in our production server and in our yum repository we have 2 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2014
    Posts
    1

    yum always installing higher version not specific version


    We use RPMS for our packaging and yum to update our environments. We have an rpm pacakge-5.1.1-3 installed in our production server and in our yum repository we have 2 higher versions of RPMS like package-5.1.3-3 and package-5.2-27.
    we tried to install 5.1.3-1 version but it installed 5.2-27. It caused serious problems in production.

    If we remove 5.2-27 package from YUM rpm repository and try installing 5.1.3-1, its installing as expected.

    I think yum should allow installation of specific version of RPMS and I remember doing this few times. I tried to debug but no success.

    HTML Code:
    yum install package-5.1.3-1
    Loaded plugins: rhnplugin, security
    Excluding Packages in global exclude list
    Finished
    Setting up Install Process
    Package matching package-5.1.3-1.x86_64 already installed. Checking for update.
    Resolving Dependencies
    --> Running transaction check
    --> Processing Dependency: package = 5.1.1-3 for package: package-database
    ---> Package package.x86_64 0:5.1.3-1 set to be updated
    --> Running transaction check
    ---> Package package-database.x86_64 0:5.2-23 set to be updated
    --> Processing Dependency: package = 5.2-23 for package: package-database
    --> Running transaction check
    ---> Package package.x86_64 0:5.1.3-1 set to be updated
    ---> Package package.x86_64 0:5.2-23 set to be updated
    --> Finished Dependency Resolution
    
    Dependencies Resolved
    
    ======================================================================================================
     Package                               Arch             Version             Repository           Size
    ======================================================================================================
     package                    x86_64           5.2-23              repo            22 M
     package-database           x86_64           5.2-23        


    Any ideas on this??

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,709
    Try adding the --exclude='package-5.2*' to your yum command options, as in: yum --exclude='package-5.2*' install package-5.1.3-1
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •