Find the answer to your Linux question:
Results 1 to 5 of 5
I am new to the linux experience, having recently installed Fedora Core 2. My main problem is that my wife does not want to use linux so I need to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    Jan 2005
    Location
    Florida
    Posts
    414

    dual booting with xp


    I am new to the linux experience, having recently installed Fedora Core 2. My main problem is that my wife does not want to use linux so I need to set up so that either xp boots automatically from grub, or that one of the os's has to be selected before booting.
    thx

  2. #2
    Banned
    Join Date
    Nov 2004
    Location
    Belgium
    Posts
    1,120
    Making Fedora Core 2 and Windows play well together(to avoid and repair problems):
    http://lwn.net/Articles/86835/

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Location
    Downey Ca
    Posts
    70
    My Fedora Core 2 Install Experience

    This by all means may not work for everybody and I can't explain why it happened I can just
    guess. I've been working with Red Hat since version 6.2. My company is going to change all our
    operating systems mid next year to Red Hat Enterprise Edition. The reason why I like Fedora is it's
    always a challenge to make it work when your running on the cutting edge of hardware.
    I want to thank all the people and their suggestions on this forum.

    I run an Intel D865perl motherboard with 2.6 gig Intel processor with 512 meg of ram. Two 80 gig
    hard drives. The first hard drive is for Windows XP. Second hard drive is for Fedora and data
    backups.

    Drive 2 the first 20 gig is Fedora and the second 60 gig is for files backups and Norton ghost 2003
    images. Which I never doing anything without a current image file it saved my butt at least 10
    times during install of Fedora Core 2.

    The first thing I ran into was the partition alignment problem. This is where it will blow up your MBR
    on your first drive. I tried everything suggested from Changing the Bios for the drive to LBA etc,etc.
    and during the install I kept seeing unable to open package hit enter to retry and there was nothing
    wrong with the cd's. But anyhow I gave up and installed everything on Fedora Core 1 and said no.
    more. The next day I decided to do an upgrade of Fedora Core 2 and canceled not ignored the
    partition alignment. When it asked to update the boot loader I said yes but put it on the first sector
    of the second drive not in the MBR. And the install started without any errors. And I was up and
    running. The next thing I saw was the KDE startup windows was out of alignment it was off the right
    not centered after that I changed the resolution to 800X600 and it centered itself and when you
    logged out if you tried to reboot you had to find the right spot for the button. It seems it was out of
    alignment also. I also noticed that the login screen didn't change it's resolution it stayed at the
    smaller fonts so I changed it to 800X600 the alignment problem went away. So far everything to this
    point is happy. A few notes: I used Partition Magic 8.0, Drake, Dos to try to stop the errors. It's
    not the partition it's Fedora Core 2 that's the problem and that should have been a show stopper.

    Now duel booting using XP boot manager (My Preference. I don't like third party boot managers.)

    Use your rescue CD to boot to Fedora.
    Run the command dd if=/dev/hda5 of=boot.lnx bs=512 count=1
    If hda5 is Not your boot partition, change it as appropriate. Type: df then determine which hda#
    is associated with your /boot partition. A file named boot.lnx should now have been created
    in the root's home directory or where ever you told it to be. Do an ls -l boot.lnx to confirm this.
    Mount your floppy drive insert a formatted dos diskette and use the command mcopy boot.lnx a:
    Or if your internet is up and running email it to yourself. Now reboot and go to Windows XP.
    A: Copy boot.lnx C:\ (It will land it in C:\ root.) Double click your boot.ini file and add one line at
    the end it should read c:\boot.lnx="Fedora Core 2". Then save it. When you reboot your XP boot
    manager will come up when you chose Fedora it jumps to the Grub Boot manager on your second
    drive. Reboot to Fedora.

    Now the sound issue (It worked for me on my motherboard sound system. Do some research for
    your motherboard sound system. This applies to a D865perl board).

    First get the six files version 1.0.4 from alsa-project.org.
    Unzip all of them to a folder. Login as root. Commands are as follows. These worked in Fedora
    Core 1 but they worked for me in Core 2.

    Change to the driver directory and run these commands.
    export CC="gcc32"
    ./configure --with-cards=intel8x0 --with-oss=yes --with-sequencer=yes
    When it finishes run
    make && make install
    When it finishes run
    ./snddevices
    When it finishes run
    chkconfig --add alsasound

    Now go to your modules.conf and your modprobe.conf files and add these lines to the end unless
    their already there.

    # Alsa Portion
    alias char-major-116 snd
    alias snd-card-0 snd-intel8x0

    # OSS/Free portion
    alias char-major-14 soundcore
    alias sound-slot-0 snd-card-0

    # card 1
    alias sound-service-0-0 snd-mixer-oss
    alias sound-service-0-1 snd-seq-oss
    alias sound-service-0-3 snd-pcm-oss
    alias sound-service-0-8 snd-seq-oss
    alias sound-service-0-12 snd-pcm-oss

    Now save it and to the same in your modprobe.conf file.

    Now go back to the root directory and run the command.

    chmod a+rw /dev/dsp /dev/mixer /dev/sequencer /dev/midi

    Now change into your lib dirctory run this command.

    ./configure;make;make install

    When thatís done do this for the directories util,firmware,oss. I've never done anything with the
    tools directory. And when I rebooted I had to reboot a couple of times then the sound started clean
    and clear.

    That's all I have for now.

  4. #4
    Just Joined!
    Join Date
    Jan 2005
    Posts
    14

    default

    you have to change in the grub configuration file, the option that says "default=X". Here, in de X, you have a number, then change it for the number of the windows.
    I hope I help

  5. #5
    Just Joined!
    Join Date
    Nov 2004
    Location
    INDIA
    Posts
    7
    type in terminal as a super user to change the default

    #vi /etc/grub.conf
    and press insert to change it
    and change the default
    type Esc and :w (enter) for save and :q(enter) to quit
    and reboot

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •