Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Broken YUM after update, kernel updated partly


    Hello all,

    Current kernel: 3.10.0-514.2.2.el7.x86_64
    CentOS Linux release 7.3.1611 (Core)

    I'm having some strange issues with my system after I had to hard reset during an update because it was stuck. The update to be installed included a kernel update. Anyways, I managed to get back into the system using an older kernel. I had some trouble with yum about duplicates and so on, but with cleaning etc. I managed to have an error free yum again and my system was again fully functional. Stubborn as I am I again tried to do the kernel update, this time from the command-line so I could follow the progress. It was done quickly so I rebooted, but I noticed there was no boot option in the GRUB menu to select the new kernel. I went to search in the /boot folder and found that yum only created the vmlinuz, but not the initramfs and did also not update the GRUB. So therefore I manually used the commands depmod , dracut and grub2-mkconfig to be able to boot the new kernel. This worked, I was able to boot and all my software worked fine!

    I'm again trying to install my graphics drivers using yum and packages I thankfully got from wolfy from ELrepo for this kernel version, but it fails me:
    Code:
    Running transaction
      Installing : kmod-fglrx-15.12-5.el7.elrepo.x86_64                         1/2 
    Working. This may take some time ...
    caps: does not work with systemd in the initramfs
    Done.
      Installing : fglrx-x11-drv-15.12-5.el7.elrepo.x86_64                      2/2 
    
    Broadcast message from systemd-journald|at|jan-linux (Wed 2017-01-11 16:46:52 CET):
    
    dracut[19272]: Failed to install module fglrx
    
    
    Message from syslogd|at|Jan-Linux at Jan 11 16:46:52 ...
     dracut:Failed to install module fglrx
    ^Ccaps: does not work with systemd in the initramfs
    Failed to install module fglrx
    caps: does not work with systemd in the initramfs
    I had a spare disk in my PC so I installed the latest version of CentOS (same version & kernel version), and the packages are good because here it can install the graphics drivers and works without any problems.

    Any ideas on how I can debug this? I somehow think that yum thinks I'm still on a different kernel version?

    Thanks already

    EDIT: Fixed it myself. Apparently the new fglrx drivers & gdm & GNOME 3.14 are not a good combination. I switched to lightdm & MATE which fixed all the issues. The message above where dracut Failed to install module fglrx was because it was trying to load the module in an older kernel version. The module for current kernel version was loading fine.
    Last edited by The_Dutchman; 01-12-2017 at 09:22 AM.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    14,003
    Glad you were able to sort it out. I have only tested (lightly) CentOS/RHEL 7.x - my server is running 6.8. In any case, please mark this thread as resolved.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •