Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    KVM in CentOS - Permission Denied


    I am having a problem using KVM in CentOS 7. I have working .vdi files (e.g., a Windows 7 guest that has run successfully in VirtualBox on Linux Mint; a newly downloaded Ubuntu Gnome 17.04 x64 .vdi from OSBoxes.com).

    The problem arises when I try to use these .vdi files in Virtual Machine Manager on CentOS. I am able to go through the setup menu process, selecting the .vdi file and so forth. All seems to go well until the end. Then I get "permission denied."

    The VM files are in an ext4 partition on the same SSD as (but in a different partition from) the CentOS program files, mounted as /run/media/ray/VMs. I'm not very skilled in permissions, but as su - > Nautilus > Properties > Permissions, for that VMs directory, I see Owner and Group = ray, Access = Create and delete files in all cases. SELinux is set to permissive mode.

    Any idea why permission would be denied in CentOS and not in Mint?

  2. #2
    Linux User
    Join Date
    Dec 2017
    Location
    Argentina
    Posts
    271
    I'm not sure if that's the problem, but you could test that by doing
    Code:
    sudo chmod 777 /run/media/Ray/VMs/name.vdi
    By the way, how are you mounting that partition? With Nautilus or via the terminal?

  3. #3
    I mounted the VMs partition using Applications > Utilities > Disks. There's no "About" menu option within that utility; not sure what that menu pick actually runs.

    I tried running the chmod command, and then retried mounting the VM using virt-manager. Same result: "Permission denied."

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    Dec 2017
    Location
    Argentina
    Posts
    271
    What exactly did you run?
    Did anyone else have the same problem?

  6. #5
    Quote Originally Posted by raywood View Post
    I am having a problem using KVM in CentOS 7. I have working .vdi files (e.g., a Windows 7 guest that has run successfully in VirtualBox on Linux Mint; a newly downloaded Ubuntu Gnome 17.04 x64 .vdi from OSBoxes.com).

    The problem arises when I try to use these .vdi files in Virtual Machine Manager on CentOS. I am able to go through the setup menu process, selecting the .vdi file and so forth. All seems to go well until the end. Then I get "permission denied."

    The VM files are in an ext4 partition on the same SSD as (but in a different partition from) the CentOS program files, mounted as /run/media/ray/VMs. I'm not very skilled in permissions, but as su - > Nautilus > Properties > Permissions, for that VMs directory, I see Owner and Group = ray, Access = Create and delete files in all cases. SELinux is set to permissive mode.

    Any idea why permission would be denied in CentOS and not in Mint?
    centos is for servers; mint is for home users. selinux and other such acls arent as strict. look at the acls for that file and make sure that qemu user/group has permissions. regular file system attributes dont enter into things here. look at getfacl and setfacl man pages.

  7. #6
    Quote Originally Posted by CarterCox View Post
    What exactly did you run?
    he said 'I tried running the chmod command" in post #3. you gave him a chmod command in post #2. then he said he ran a chmod command in post #3. and in post #4 you cant figure out what he ran? wow.

  8. #7
    Linux User
    Join Date
    Dec 2017
    Location
    Argentina
    Posts
    271

    Thumbs down

    Quote Originally Posted by habit View Post
    he said 'I tried running the chmod command" in post #3. you gave him a chmod command in post #2. then he said he ran a chmod command in post #3. and in post #4 you cant figure out what he ran? wow.
    Seems that hate has made you dumb and blind. I'll explain: I told him to run "sudo chmod 777 /run/media/Ray/VMs/name.vdi", but he really should run "sudo chmod 777 /run/media/Ray/VMs/actual name.vdi". I was asking for a copy/paste of the command in case there were any errors.I hope that wasn't too advanced.

  9. #8
    Quote Originally Posted by CarterCox View Post
    Seems that hate has made you dumb and blind.
    says the guy that cant read one thread to the next.
    I'll explain: I told him to run "sudo chmod 777 /run/media/Ray/VMs/name.vdi", but he really should run "sudo chmod 777 /run/media/Ray/VMs/actual name.vdi". I was asking for a copy/paste of the command in case there were any errors.I hope that wasn't too advanced.
    keep digging, ****tard. not everyone else is as stupid as you.

    you know damned well he ran the command you gave him and that hes not as stupid as you are, and changed the name. keep trying to split hairs to make yourself look less stupid. amazing you dont go to another forum with your great advice. mainly because youd be shredded there, by LOTS of other smarter people. you only post here because you can get away with this crap.

  10. #9
    Linux User
    Join Date
    Dec 2017
    Location
    Argentina
    Posts
    271
    Quote Originally Posted by habit View Post
    you know damned well he ran the command you gave him and that hes not as stupid as you are, and changed the name. keep trying to split hairs to make yourself look less stupid.
    Lol... How was I supposed to know?

  11. #10
    Quote Originally Posted by CarterCox View Post
    Lol... How was I supposed to know?
    by getting both of your brain cells to work together and think about things? lol yea, again..keep digging, ****tard.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •