Find the answer to your Linux question:
Results 1 to 3 of 3
ok i have tried both wvdial and kpp both and gotten the same response. Whenever i try to dial with my modem i get the dial tone i pick up ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    78

    Modem Dialing Big Problem


    ok i have tried both wvdial and kpp both and gotten the same response. Whenever i try to dial with my modem i get the dial tone i pick up the phone and listen to it dial. it then proceeds to negotiate and i hear it connect and everything but the logs say it checks for a Carrier and then it says No Carrier and stops everything.

    I have looked and looked and it tells me all kinds of ways to disable the Carrier Check and none of them have worked thus far. Some of the ways were to put in an option 'Carrier Check = 0' and another 'Carrier Check = no' and the final that i tried myself was 'Carrier Check = off' does anyone else have an idea of how to fix this problem or how to disable the Carrier Check?

    All help is greatly appreciated,
    ~TriggerGuard

    ---------------------------------------


    (wvdial.con)
    [Modem0]
    Modem = /dev/modem
    Baud = 115200
    SetVolume = 2
    Dial Command = ATDT
    Init1 = ATZ
    Init3 = ATM1L2
    FlowControl = CRTSCTS
    [Dialer ev1]
    Carrier Check = no
    Username = ????
    Password = ????
    Phone = 9794139007
    Stupid Mode = 1
    Init1 = ATZ
    Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    Inherits = Modem0



    (log)
    ---> Modem initialized.
    ---> Sending: ATDT <Phone Number>
    ---> Waiting for carrier
    ATDT<Phone Number>
    NO CARRIER

  2. #2
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    If you hear it connect, then I don't think changing "carrier check" will help. I would guess that the carrier is getting dropped by the other end. I had a similar problem, and maybe I'm a little slow, but it was a simple matter of entering my user name in its fully qualified form, that is, not just 'yourname' but rather 'yourname@yourisp.net'. Maybe that's not the problems, but it's probably some detail in your handshake procedure.
    /IMHO
    //got nothin'
    ///this use to look better

  3. #3
    Just Joined! jordower's Avatar
    Join Date
    Feb 2005
    Posts
    64
    im having the exact same problem
    i've tried using username@isp.com instead of just username and it still doesnt work
    to make things even more frustrating, it was working perfectly (both kppp and wvdial) when i visiting relatives last week where i had to use a ten digit number, might that have something to do with it? (it's the same ISP at home as at the relative's house, so that shouldnt be an issue)

    any help or ideas would be greatly appreciated

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •