Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 22
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11

    Quote Originally Posted by jens
    Hi,
    First of all, a kernel source is not needed in FC3.
    All needed headers now come with the kernel package itself(that is, if you use the fedora kernels).

    No precompiled kernel interface was found to match your kernel.
    Why did you stop here?
    You don't need a precompiled interface...
    Next the installer should ask to build it itself (using the headers that now come with the kernel package).

    Their's a much easier way to install your nvidia driver though:
    http://www.fedorafaq.org/#nvidia
    who said t o stop there?

  2. #12
    Linux Enthusiast
    Join Date
    Jun 2004
    Location
    Windsor, CO
    Posts
    656
    1. Kernel source not needed in FC3
    2. You don't want the precompiled interface, you want it to compile it's own interface, don't quit after just that message.
    3. Make sure you follow the README file's instructions too.

    Also, I find the simplest way to close X and run from CLI is just open a terminal in the GUI and then enter:
    Code:
    su
    init 3
    Emotions are the key to the soul.
    Registered Linux User #375050

  3. #13
    Just Joined!
    Join Date
    Feb 2005
    Location
    Finland
    Posts
    5
    [quote="jens"]Hi,
    First of all, a kernel source is not needed in FC3.
    All needed headers now come with the kernel package itself(that is, if you use the fedora kernels).

    No precompiled kernel interface was found to match your kernel.
    Why did you stop here?
    You don't need a precompiled interface...
    Next the installer should ask to build it itself (using the headers that now come with the kernel package).

    I have an identical problem to above and the installer did ask to build itself, but I got:

    Unable to find developement tool 'cc' in your path. Make sure gcc is installed and check 'cc' is in your path. I'm a newcommer to Linux and I don't know what any of this means or how to do it.

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Newbie
    Join Date
    Oct 2004
    Location
    de
    Posts
    103
    cc means "C Compiler" and is normally linked to gcc, the GNU Compiler Collection. Make sure you have gcc installed. You can find it here. It is shipped with most distros, look for it in your package manager in the section "development tools".

    If you have installed it, and the error still occurs, you have to symlink it yourself: (Do this with su)
    Code:
    ln -s gcc /usr/bin/cc
    --LC
    it\'s !Linux; it\'s GNU/Linux!
    [XBill] [GNU] [Viewable with Any Browser] [Drop me a mail]

  6. #15
    Just Joined!
    Join Date
    Feb 2005
    Location
    Your SQL Server
    Posts
    95
    when i type in init 3, its says command not found, so i ran locate init, and it was in my sbin, so i ran /sbin/init 3, and i went to a blank screen where the login failed to appear. i don't know what happened but when i do get into run level three ( i forgot how i did ), then i cannot go back to run level 5, i type in /sbin/init 5 and nothing happens

  7. #16
    Just Joined!
    Join Date
    Feb 2005
    Location
    Finland
    Posts
    5

    Hello again

    Quote Originally Posted by LC
    cc means "C Compiler" and is normally linked to gcc, the GNU Compiler Collection. Make sure you have gcc installed. You can find it here. It is shipped with most distros, look for it in your package manager in the section "development tools".

    If you have installed it, and the error still occurs, you have to symlink it yourself: (Do this with su)
    Code:
    ln -s gcc /usr/bin/cc
    --LC
    Thanks for the help. I have been trying for some time to install the nVidia driver. I first tried yum install for my kernel (2.6.10-1.760). The system boots up but hangs before entering the GUI with a nVidia logo on the screen. The mouse pointer leaves patterns all over the screen when I move it around. I yum installed gcc and the nVidia driver installed itself. I got a message

    module liicense 'NVIDIA' taints kernel.

    which I ignored. I also got a message at the end that the rivafb driver may be loaded by the kernel and that I should dissable this. I was going to see if info about this is available on the nVidia site. So I'm not sure if the kernel is tainted (or if this is normal) or if I should dissable the rivafb, and how to do it.

    I wondered if I should have yum installed after leaving xwindows (is this possible?) as the nVidia driver needs to be installed in that way. As I say I have at best a rudimentary understanding of Linux (or indeed any OS) and I feel like I'm feeling my way in the dark.

  8. #17
    Banned
    Join Date
    Nov 2004
    Location
    Belgium
    Posts
    1,120
    I'm a little confused here...
    So the installer successfully worked ?
    Can you still boot ?
    What exactly are your problems ?

    As for those warnings, ignore both.

  9. #18
    Just Joined!
    Join Date
    Feb 2005
    Location
    Finland
    Posts
    5

    Can't get into GUI

    Quote Originally Posted by jens
    I'm a little confused here...
    So the installer successfully worked ?
    Can you still boot ?
    What exactly are your problems ?

    As for those warnings, ignore both.
    Maybe I didn't explain it very well. At first I tried to yum install the nVidia driver. The computer boots up but freezes before it enters the GUI. I got a screen displaying the nVidia logo, but the computer just didn't go into the GUI. The mouse pointer could move around the screen but left little marks over the screen. I removed the yum driver and installed the driver from the nVidia site. I closed xwindows. I made the recomended changes to the xorg.conf and did modprobe nvidia. then I did
    cp -a /dev/nvidia* /etc/udev/devices
    chown root.root /etc/udev/devices/nvidia

    I got all the info from a howto, but can't confess to understanding it entirely. But I have the same problem as before, the computer boots up, but I get to a screen displaying the nVidia logo and nothing else, with the same behaviour from the mouse. I can do [ctl] F1 to get to the non GUI interface, but can't get into the GUI at all.

  10. #19
    Banned
    Join Date
    Nov 2004
    Location
    Belgium
    Posts
    1,120
    Could you post your xorg.conf ?

  11. #20
    Just Joined!
    Join Date
    Feb 2005
    Location
    Finland
    Posts
    5

    Here is my xorg.conf

    Quote Originally Posted by jens
    Could you post your xorg.conf ?

    # Xorg configuration created by system-config-display

    Section "ServerLayout"
    Identifier "single head configuration"
    Screen 0 "Screen0" 0 0
    InputDevice "Mouse0" "CorePointer"
    InputDevice "Keyboard0" "CoreKeyboard"
    EndSection

    Section "Files"

    # RgbPath is the location of the RGB database. Note, this is the name of the
    # file minus the extension (like ".txt" or ".db"). There is normally
    # no need to change the default.
    # Multiple FontPath entries are allowed (they are concatenated together)
    # By default, Red Hat 6.0 and later now use a font server independent of
    # the X server to render fonts.
    RgbPath "/usr/X11R6/lib/X11/rgb"
    ModulePath "/usr/X11R6/lib/modules"
    FontPath "unix/:7100"
    EndSection

    Section "Module"
    Load "dbe"
    Load "extmod"
    Load "fbdevhw"
    Load "record"
    Load "freetype"
    Load "type1"
    Load "glx"
    #Load "dri"
    EndSection

    Section "InputDevice"

    # Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
    # Option "Xleds" "1 2 3"
    # To disable the XKEYBOARD extension, uncomment XkbDisable.
    # Option "XkbDisable"
    # To customise the XKB settings to suit your keyboard, modify the
    # lines below (which are the defaults). For example, for a non-U.S.
    # keyboard, you will probably want to use:
    # Option "XkbModel" "pc102"
    # If you have a US Microsoft Natural keyboard, you can use:
    # Option "XkbModel" "microsoft"
    #
    # Then to change the language, change the Layout setting.
    # For example, a german layout can be obtained with:
    # Option "XkbLayout" "de"
    # or:
    # Option "XkbLayout" "de"
    # Option "XkbVariant" "nodeadkeys"
    #
    # If you'd like to switch the positions of your capslock and
    # control keys, use:
    # Option "XkbOptions" "ctrl:swapcaps"
    # Or if you just want both to be control, use:
    # Option "XkbOptions" "ctrl:nocaps"
    #
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "IMPS/2"
    Option "Device" "/dev/input/mice"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "yes"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Monitor Vendor"
    ModelName "C776"
    DisplaySize 320 240
    HorizSync 30.0 - 72.0
    VertRefresh 50.0 - 160.0
    Option "dpms"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "nvidia"
    VendorName "Videocard vendor"
    BoardName "RIVA TNT2"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    Monitor "Monitor0"
    DefaultDepth 16
    SubSection "Display"
    Viewport 0 0
    Depth 16
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    EndSection

    Section "DRI"
    Group 0
    Mode 0666
    EndSection


    I added
    Load "glx"
    commented out
    #Load "dri"
    in the "Module" section and in the "Device" section I changed
    Driver "nv"
    to
    Driver "nvidia"

    Any suggestions greatly appreciated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •