Find the answer to your Linux question:
Results 1 to 8 of 8
I have a FAT32 shared partition on my box, and I don't have write permissions on it outside of root. I've tried chmod og+wrx /shared and chmod a+wrx /shared, but ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    6

    Write Permissions


    I have a FAT32 shared partition on my box, and I don't have write permissions on it outside of root. I've tried chmod og+wrx /shared and chmod a+wrx /shared, but neither worked. Instead, I not only didn't get write permissions, but actually lost read permissions. Using the GUI version doesn't help, since I'll check off permissions for both group and others, and it reverts as soon as I click OK. I've tried this as both root and su inside the user I wanted to give permissions to, but nothing works. It's now listed as "forbidden" for everyone except root. Thanks in advance.

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    As root, try:
    Code:
    chmod 755 -R /shared

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    6
    That gave me read permissions...but once I leave the GUI they go away again, and I have to retype the command. Is there a way to give myself permanent permissions? Also I still don't have write permissions. Thanks a bunch though!

  4. #4
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    weird.....but i remember something like this in suse *loft306 smacks self with kb trying to shake thought loose
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  5. #5
    Just Joined!
    Join Date
    Jan 2005
    Location
    Los Angeles
    Posts
    40
    check out this thread: http://www.linuxforums.org/forum/top...tml&highlight=

    I ran into the same problem trying to sync firefox bookmarks on the windows and linux sides. The answer lies in editing your fstab. It should be pretty easy if you look in the man page. I'm on the windows side of my machine right now, so I can't check

  6. #6
    Just Joined!
    Join Date
    Feb 2007
    Location
    Riga, Latvia, EU
    Posts
    2

    Smile

    Simlar problem here:
    Under root account I made FAT32 partition. Everything worked ok. When I logon with unprivilaged account I can access the disk read-only.
    I could not change the permission with chmod. With parameter -v it said that permissions are changed, but it didn't.
    When I loged on with root account and tried to change permissions with graphical tool (in Nautilis) it said I didn't had permissions to do that in FAT (like there is anyone else more cool in LInux world )
    Interesting enough, I had no problems of such kind in NTFS.

    I have Fedora Core 6
    Kernel 2.6.19.what's.his.name

    P.S. As far as I can remember, there are no permission system of any kind under FAT

  7. #7
    Just Joined!
    Join Date
    Feb 2007
    Location
    Adelaide, Australia
    Posts
    53
    someone that is having this problem can you please paste a copy of your fstab file and the output of mount

  8. #8
    Just Joined!
    Join Date
    Feb 2007
    Location
    Riga, Latvia, EU
    Posts
    2
    Mounting:
    [ego@atlas ~]$ sudo mount -v -t vfat /dev/hdb1 /home/ego/Desktop/fat/
    /dev/hdb1 on /home/ego/Desktop/fat type vfat (rw)

    Fstab:
    [ego@atlas ~]$ vi /etc/fstab

    LABEL=/ / ext3 defaults 1 1
    devpts /dev/pts devpts gid=5,mode=620 0 0
    tmpfs /dev/shm tmpfs defaults 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs defaults 0 0
    LABEL=SWAP-sda3 swap swap defaults 0 0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •