Find the answer to your Linux question:
Results 1 to 3 of 3
My Fedora Core 3 Install This by all means may not work for everybody and I can't explain why it happened I can just guess. I've been working with Red ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Location
    Downey Ca
    Posts
    70

    Duel Booting Windows XP and Fedora Core 3


    My Fedora Core 3 Install

    This by all means may not work for everybody and I can't explain why it happened I can just
    guess. I've been working with Red Hat since version 6.2. My company is going to change all our
    operating systems mid next year to Red Hat Enterprise Edition. The reason why I like Fedora is it's
    always a challenge to make it work when your running on the cutting edge of hardware.
    I want to thank all the people and their suggestions on this forum.

    I run an Intel D865perl motherboard with 2.6 gig Intel processor with 1 gig of ram. Two 160 gig
    hard drives. The first hard drive is for Windows XP. Second hard drive is for Fedora and data
    backups.

    Drive 2 the first 40 gig is Fedora and the second 120 gig is for files backups and Norton ghost 2003
    images. Which I never doing anything without a current image file it will save your butt.

    Install Fedora Core 3 on the second hard drive and use the automatic partitioning tool but don't
    put grub on your Master MBR put it on the first sector on your second drive. When you get to the
    Boot Loader Configuration screen make sure you check the Configure advanced boot loader
    options. The next screen will give the option where to put Grub Boot Loader. It should say like
    hda or hdb. Hda is usually your XP Drive. From their finish loading. Put it on hdb.

    Now duel booting using XP boot manager (My Preference. I don't like third party boot managers.)

    Use your rescue CD to boot to Fedora.
    Hit enter at the boot prompt.
    Hit enter for English
    Hit enter for us
    Setup network select no
    At the rescue screen select continue
    At the next rescue screen hit enter
    Now you have a prompt sh-3.00#
    At the prompt type in chroot /mnt/sysimage
    If hdb2 is Not your boot partition, change it as appropriate. Type: df then determine which hda#
    Run the command dd if=/dev/hdb2 of=boot.lnx bs=512 count=1
    You should see
    1+0 records in
    1+0 records out
    Type ls and you should see a file named boot.lnx
    Put a blank floppy disk in your a: drive
    Type mcopy boot.lnx a:
    It should have copied the file to your a: drive

    Now reboot to Windows

    Copy boot.lnx to your root directory
    Right click on your boot.ini file select properties and uncheck read only click ok
    Double click your boot.ini file and add one line at the end it should read
    C:\boot.lnx="Fedora Core 3". Then save it. When you reboot your XP boot
    manager will come up and you can chose Fedora it jumps to the Grub Boot manager on your
    second drive.

    My file looks like this

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(0)(1)\win dows
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(0)(1)\windows="Mi crosoft Windows XP Pro SP2"
    /fastdetect /NoExecute=OptIn
    c:\boot.lnx="RedHat Fedora Core 3 Project"

    You call it anything you want

  2. #2
    Just Joined!
    Join Date
    Feb 2005
    Posts
    1

    Fedora Core 3 Dual Installl

    I followed everything u said in the thread but the FC3 Grub always boots first. I had to manually set a Windows Xp selection on grub.config so I could boot up to windows (follow the "boot to windoes" steps). Once I select Windows from the GRUB I get the Windows Loader but when I select Fedora the screen displays "GRUB" and hangs there. What could be wrong?

    How can I make the Windws Loader come up first?

    I have the following drive config:

    2 HDs 120 GB RAID 0 having only WinXp
    1 IDE 120 GB IDE Slave Drive having only FC3.

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Location
    Downey Ca
    Posts
    70
    I don't know much about Raid Drives. But from your post It sounds like you put grub on drive 1 or 2. And it should have been on drive 3. From what I've read people are having trouble with raid Drive in Fedora. As far as grub hanging like you say I've had that happen to me and I had to reload Fedora. I tried the fixes that are out there to correct it and the easiest way I found was to reload.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •