Find the answer to your Linux question:
Results 1 to 4 of 4
just downloaded gimp 2.2 and it don't not work :- [root@localhost RPMS]# gimp (gimp:4434): Gdk-WARNING **: locale not supported by Xlib (gimp:4434): Gdk-WARNING **: can not set locale modifiers (gimp:4434): ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190

    GIMP 2.2 not working with FDC 3


    just downloaded gimp 2.2 and it don't not work :-
    [root@localhost RPMS]# gimp

    (gimp:4434): Gdk-WARNING **: locale not supported by Xlib

    (gimp:4434): Gdk-WARNING **: can not set locale modifiers

    (gimp:4434): GLib-GObject-WARNING **: specified class size for type `GimpContainerEntry' is smaller than the parent type's `GtkEntry' class size

    (gimp:4434): GLib-GObject-CRITICAL **: file gtype.c: line 2319 (g_type_add_interface_static): assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

    (gimp:4434): GLib-GObject-CRITICAL **: file gobject.c: line 819 (g_object_new): assertion `G_TYPE_IS_OBJECT (object_type)' failed

    (gimp:4434): Gimp-Widgets-CRITICAL **: file gimpcontainerview.c: line 535 (gimp_container_view_set_preview_size): assertion `GIMP_IS_CONTAINER_VIEW (view)' failed

    (gimp:4434): Gimp-Widgets-CRITICAL **: file gimpcontainerview.c: line 306 (gimp_container_view_set_container): assertion `GIMP_IS_CONTAINER_VIEW (view)' failed

    (gimp:4434): Gimp-Widgets-CRITICAL **: file gimpcontainerview.c: line 450 (gimp_container_view_set_context): assertion `GIMP_IS_CONTAINER_VIEW (view)' failed

    (gimp:4434): Gtk-CRITICAL **: file gtkwidget.c: line 5592 (gtk_widget_set_size_request): assertion `GTK_IS_WIDGET (widget)' failed

    (gimp:4434): Gtk-CRITICAL **: file gtkbox.c: line 373 (gtk_box_pack_start): assertion `GTK_IS_WIDGET (child)' failed
    Segmentation fault

    [root@localhost RPMS]# uname -r
    2.6.9-1.667


    [root@localhost RPMS]# rpm -qa | grep "gimp"
    gimp-print-plugin-4.2.7-2
    gimp-2.2.3-0.fc3.2
    xsane-gimp-0.92-13
    gimp-gap-2.0.2-2
    gimp-docs-2.0.0-1
    gimp-print-utils-4.2.7-2
    gimp-data-extras-1.2.0-12
    gimp-print-4.2.7-2


    [root@localhost home]#ls gimp*.rpm -alF
    -rw-rw-r-- 1 tony tony 9834679 Feb 18 19:00 gimp-2.2.3-0.fc3.2.i386.rpm
    anybody got any ideas of how to get around this on my Fedora Core 3 system?

    thanks

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  2. #2
    Just Joined!
    Join Date
    Feb 2005
    Location
    Netherlands
    Posts
    4

    try installing gimp by apt4rpm?

    Hi Nerderello, other readers,

    I'm running FC3 and just updated the Gimp to 2.2; can't recall if it were from 2.1 or 2.0.

    I usually install as much as possible by apt4rpm, via synaptic. For me, the Gimp is working as it should.

    Since I'm not that good at hacking, I can't find out where the problem in your system is. I'll tell you how I got it running then.

    I am using repositories from DAG Wieers, and some others. It is a groep of some four repositories that work together, and they provide an RPM to install apt for FC3 and an clear howto for adding their repositories. After that you could install synaptic to have a nice GUI for updating your system. Works great for me :-)

    Good luck !

  3. #3
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    thanks, I'll give it a look.

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    turns out I had to upgrade the Gimp Tool Kit 2, so I did a quick "rpm -U" for

    gtk2-2.4.14-2.fc3.i386.rpm

    and

    gtk2-devel-2.4.14-1.fc3.i386.rpm

    and it now works a treat.

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •