Find the answer to your Linux question:
Results 1 to 8 of 8
I am a first time user of Linux and have a little problem. I cannot connect to the internet. I have an ADSL modem connected via a router. When Fedora ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Location
    Denmark
    Posts
    6

    No internet in Fedora?


    I am a first time user of Linux and have a little problem.

    I cannot connect to the internet. I have an ADSL modem connected via a router.

    When Fedora is starting up i get a message about IP info for eth0 failed - no link - check the cable. But it works fine in windows so there is not a problem with the caple.

    The same when i am trying to connect in the network options.

    I have also tried in Mandrake 10.0 and it was just the same. Strangely it works fine in Knoppix.

    Anyone know what the problem could be?

  2. #2
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    what model of router and adsl modem?
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  3. #3
    Linux Engineer
    Join Date
    Aug 2004
    Posts
    826
    Perhaps your network interface is not supported in Fedora or Mandrake, but if it works in Knoppix I don't see why this is. Boot up Knoppix and see what driver it's using and any other info. The command ifconfig will probably tell you all the information you need to know.

  4. #4
    Just Joined!
    Join Date
    Feb 2005
    Location
    Denmark
    Posts
    6
    Quote Originally Posted by Flatline
    what model of router and adsl modem?
    Router: D-Link DI-604
    Adsl modem: SpeedStream 5100

    Sether:
    Ok i will try booting Knoppix up.
    A friend of mine just borrowed my Knoppix cd and got no empty ones left.

  5. #5
    Just Joined!
    Join Date
    Feb 2005
    Location
    Denmark
    Posts
    6
    I've run "Ifconfig" in Fedora, if this could help.

    Came up with this:

    Eth0
    Link encap: ethernet Hwaddr 00:02:44:4F:B5:00
    Inet addr: 192.168.0.100 Bcast: 192.168.0.255 Mask 255.255.255.0
    Inet6 addr: fe80: : 202:44ff:fe4:b500/64 Scope: link
    Up broadcasr running multicast MTU:1500 Metric: 1
    Rx packets: 147 errors: 0 dropped: 0 Overuns: 0 frame: 0
    Tx packets: 31 errors: 0 dropped: 0 carrier: 0 collissions: 0 txqueuelen: 1000

    Rx bytes: 12739 (12,4kb) Tx bytes: 3290 (3,2kb)
    Interupt: 11 base address:0xec00

    lo
    Link encap: local loopback
    inet addr: 127.0.0.1 Mask: 255.0.0
    Inet6 addr: :: 1/128 Scope: Host
    Rx packets: 2213 errors: 0 dropped: 0 overuns: 0 frame: 0
    Tx packets: 2213 errors: 0 dropped: 0 overuns: 0 carrier: 0 collossions: 0 txqueuelen: 0

    Rx bytes: 2467742 (2,3mb) Tx bytes: 2467742 (2,3mb)

  6. #6
    Linux User
    Join Date
    Jan 2004
    Posts
    357
    It looks like you are getting an ip address from the router
    Inet addr: 192.168.0.100
    but are you getting you dns server settings? What's in /etc/resolv.conf
    in a terminal type something like
    Code:
    cat /etc/resolv.conf

  7. #7
    Just Joined!
    Join Date
    Feb 2005
    Location
    Denmark
    Posts
    6
    Quote Originally Posted by logan5
    What's in /etc/resolv.conf
    in a terminal type something like
    Code:
    cat /etc/resolv.conf
    Getting this:

    nameserver 195.82.195.101
    nameserver

    I don't know what has happened but i wrote dhclient eth0 again and now it just worked, so the problem is gone.

    Thank you all.

  8. #8
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    Ah, gotta love the magic spontaneous repair. At least it's working now
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •