Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 16 of 16
Originally Posted by supermaneddie I tried to execute the command "su - apache", but the system report "This account is currently not available. Is that this issue to cause the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512

    Quote Originally Posted by supermaneddie
    I tried to execute the command "su - apache", but the system report "This account is currently not available. Is that this issue to cause the problem?
    Ok try this then,
    Code:
    ps xua | grep 'http'
    You should get a few lines like this as a reply
    Code:
    root     10679  0.0  0.7 37736 7824 ?        S    Feb28   0:19 /usr/sbin/httpd
    apache   16471  0.0  1.0 38712 10636 ?       S    Mar06   0:00 /usr/sbin/httpd
    The first column will tell you which user the HTTP/Apache service is run as.
    As from above example, http is started as root, but switched over to user "Apache". However, substitue my previous example with the user you have in your system.
    Could be "nobody", "http", "root".

    However, if your user is "root", consider re-configure your system due to security issues.

  2. #12
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    Quote Originally Posted by supermaneddie
    Is that the problem of fat32?
    Could be, it is dependent on how you have mounted your fat32 partition.

  3. #13
    Just Joined!
    Join Date
    Mar 2005
    Posts
    11
    Quote Originally Posted by swemic
    Quote Originally Posted by supermaneddie
    I tried to execute the command "su - apache", but the system report "This account is currently not available. Is that this issue to cause the problem?
    Ok try this then,
    Code:
    ps xua | grep 'http'
    You should get a few lines like this as a reply
    Code:
    root     10679  0.0  0.7 37736 7824 ?        S    Feb28   0:19 /usr/sbin/httpd
    apache   16471  0.0  1.0 38712 10636 ?       S    Mar06   0:00 /usr/sbin/httpd
    The first column will tell you which user the HTTP/Apache service is run as.
    As from above example, http is started as root, but switched over to user "Apache". However, substitue my previous example with the user you have in your system.
    Could be "nobody", "http", "root".

    However, if your user is "root", consider re-configure your system due to security issues.
    I get
    Code:
    root      3206  0.0  0.9 19236 10084 ?       Ss   06:38   0:00 /usr/sbin/httpd
    apache    3242  0.0  0.9 19372 10220 ?       S    06:38   0:00 /usr/sbin/httpd
    apache    3243  0.0  0.9 19372 10220 ?       S    06:38   0:00 /usr/sbin/httpd
    apache    3244  0.0  0.9 19372 10220 ?       S    06:38   0:00 /usr/sbin/httpd
    apache    3245  0.0  0.9 19520 10324 ?       S    06:38   0:00 /usr/sbin/httpd
    apache    3246  0.0  0.9 19372 10228 ?       S    06:38   0:00 /usr/sbin/httpd
    apache    3247  0.0  0.9 19372 10228 ?       S    06:38   0:00 /usr/sbin/httpd
    apache    3248  0.0  0.9 19372 10220 ?       S    06:38   0:00 /usr/sbin/httpd
    apache    3249  0.0  0.9 19372 10220 ?       S    06:38   0:00 /usr/sbin/httpd
    And my mount option in my fstab is:
    Code:
    /dev/hda7    /mnt/share1    vfat    gid=50,umask=0,rw,user
    It look like is 777 permission, gid=50 is the ftp group

  4. #14
    Just Joined!
    Join Date
    Feb 2005
    Posts
    5
    I suggest you look at the info here:

    http://library.n0i.net/linux-unix/ad...rt1/fstab.html

    Don't know why you have defined gid in that line in your fstab? But that is defining permissions and you probably should consider dropping it.

    Cheers

  5. #15
    Just Joined!
    Join Date
    Mar 2005
    Posts
    11
    Quote Originally Posted by NoStop
    I suggest you look at the info here:

    http://library.n0i.net/linux-unix/ad...rt1/fstab.html

    Don't know why you have defined gid in that line in your fstab? But that is defining permissions and you probably should consider dropping it.

    Cheers
    because I would like to mount this partition for all user which belongs to group "FTP", and umask is define the 777 permission, so it should be no meaning for gid

  6. #16
    Just Joined!
    Join Date
    Sep 2011
    Posts
    1
    Quote Originally Posted by supermaneddie View Post
    I tried to execute the command "su - apache", but the system report "This account is currently not available. Is that this issue to cause the problem?
    may be because your apache don't have login permission,
    you can add it in /etc/passwd
    like this
    "apache:48:48:Apache:/var/www:/bin/bash"

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •