Find the answer to your Linux question:
Results 1 to 7 of 7
using redhat 9.0 ... having permission problems.... im using the graphical interface firstly lets talk FTP ... im semi noob with linux.. but im quick with computers and figuring things ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    8

    Permissions,Permissions,Permissions


    using redhat 9.0 ... having permission problems....
    im using the graphical interface

    firstly lets talk FTP ...

    im semi noob with linux.. but im quick with computers and figuring things out

    ok im running the ftp server for redhat
    i cant log in with root remotly but thats ok
    i have any number of users created in the users controll panel thing
    ive set each of their home directories there but i dont know if that applys at all to the ftp server... however i can login with each of their accounts and passwords to the ftp server but it takes me to the computers "/" dir.
    biggest issue is i cant login from remote... i can log in any internal ip's or from self but from the internet it is not accesable at all

    Questions
    how can i tell it where a users ftp root should be?
    how can i make it accesable from the internet?



    thanks
    kyle ..

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    what ftp daemon are you running (i.e. vsftpd, proftpd, etc)

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Posts
    8
    vsFTPd 1.1.3 i belive thats default with redhat 9 ...

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Apr 2003
    Location
    London, UK
    Posts
    3,284

    Re: Permissions,Permissions,Permissions

    Quote Originally Posted by kage
    biggest issue is i cant login from remote... i can log in any internal ip's or from self but from the internet it is not accesable at all
    Check your firewall settings for that. Make sure you're allowing TCP ports 20 and 21 through. If you're going through a router make sure your router is configured to forward those ports correctly.

    how can i tell it where a users ftp root should be?
    This is specified as the home directory in the /etc/passwd file.

    how can i make it accesable from the internet?
    See above.

  6. #5
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    you might also want to check out the vsftpd.conf manpage:
    Code:
    man 5 vsftpd.conf

  7. #6
    Just Joined!
    Join Date
    Mar 2005
    Posts
    8
    i have the firewall turned off to see if thats the problem and it doesnt seem to be evin still whats the file for ther firewall settings? the graphical interface doesnt allow me to set ports just services ... my router is forwarding 20~25 to that address...

    furthermore connectin with a client from windows (bulleproof) i get stuff like this

    Code:
    227 Entering Passive Mode (192,168,1,109,39,96)
    Connecting to archives.no-ip.org port 10080
    Data Connection opened.
    STOR /var/www/html/images/what-retry.bmp
    553 Could not create file.
    Error uploading file, I tried 2 times but that didn't work.
    Make sure you're uploading to the correct directory and try again.
    Data Connection closed
    i dont see why itaas trying to connect on port 10080 but i found a setting for max and min ports in the FAQ for the ftpd, and i restricted it from 10000 ~ 10100 and my routers forwarding thoes as well ...

    on teh other hand a ftp connection with IE just says "bad ip connect" .... ??

    i opened up that file and set the home dir for a person to be the /var/www but logging in with ftp it just takes them to the "/" however interestingly enough they are able to upload files and such


    hmm on further investigation ivew determined i think that a problem is that the user "kyle" (my user im loggin in weith on ftp) is part of the group "kyle" and that group is only set as user of some of thoes files/folders without the proper permissions... instead of go and change the permissions on thousands of files in the folder is tehre a way to blanket set the permissions ...?

    Questions
    why does it connect on thoes ports??
    how can i blanket set permisions?
    how can i change it so that user can only login to that dir and none other?and theres still teh bad ip issue



    thanks and sorry for all the questions wich mite seem annoying

  8. #7
    Just Joined!
    Join Date
    Mar 2005
    Posts
    8
    anyone, ne ideas??

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •