Find the answer to your Linux question:
Results 1 to 3 of 3
Hi all, I was wondering if anyone knew of a non-mind bending way to disable fstab-sync. I'm tired of it and hal overwriting fstab every time I reboot, leaving most ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    11

    FC3 -- Disabling fstab-sync


    Hi all,

    I was wondering if anyone knew of a non-mind bending way to disable fstab-sync. I'm tired of it and hal overwriting fstab every time I reboot, leaving most of my drives unmountable (I'm not really sure why, but it does, so I edit fstab again, and when I reboot, I have to go back and change it again).

    The man 8 page for fstab-sync gave me these instructions:

    DISABLING FSTAB-SYNC
    Automatic updates of the /etc/fstab file by the fstab-sync program from
    the HAL daemon can be disabled by changing the 50-fstab-sync.hal sym-
    link in /etc/hal/device.d directory to point to /bin/false

    I read up on linking, but when I try to softlink 50-fstab-sync.hal to /bin/false, I get the following error (I'm including the command I issued as well):

    [root@localhost device.d]# ln -s 50-fstab-sync.hal /bin/false
    ln: `/bin/false': File exists

    Any suggestions on how to unlink 50-fstab-sync.hal and link it to /bin/false without running the risk of deleting/corrupting important system files?? Any help would be greatly appreciated! Thanks!

  2. #2
    Just Joined!
    Join Date
    Feb 2005
    Posts
    11

    Re: FC3 -- Disabling fstab-sync

    Quote Originally Posted by bradmatic
    Hi all,

    I was wondering if anyone knew of a non-mind bending way to disable fstab-sync. I'm tired of it and hal overwriting fstab every time I reboot, leaving most of my drives unmountable (I'm not really sure why, but it does, so I edit fstab again, and when I reboot, I have to go back and change it again).

    The man 8 page for fstab-sync gave me these instructions:

    DISABLING FSTAB-SYNC
    Automatic updates of the /etc/fstab file by the fstab-sync program from
    the HAL daemon can be disabled by changing the 50-fstab-sync.hal sym-
    link in /etc/hal/device.d directory to point to /bin/false

    I read up on linking, but when I try to softlink 50-fstab-sync.hal to /bin/false, I get the following error (I'm including the command I issued as well):

    [root@localhost device.d]# ln -s 50-fstab-sync.hal /bin/false
    ln: `/bin/false': File exists

    Any suggestions on how to unlink 50-fstab-sync.hal and link it to /bin/false without running the risk of deleting/corrupting important system files?? Any help would be greatly appreciated! Thanks!
    Anyone who wants to disable the updating feature of fstab-sync without going through all the trouble of unlinking and relinking files can just take out the "managed" line in each fstab entry (usually for your cdrom, floppy, and zip drives -- or any other drives which you noticed that fstab automatically found on a bootup). See this link for more details.

  3. #3
    Linux Newbie
    Join Date
    Jul 2004
    Location
    Calcutta, India
    Posts
    220
    man !! you are doing just the opposite !!
    syntax of ln says 1st target then link name.
    do the following :

    ln -s /bin/false /etc/hal/device.d/50-fstab-sync.hal

    btw, you may have to first delete the 50-fstab-sync.hal symlink.
    Neway, since your problem has been solved already so dont bother about this.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •