Find the answer to your Linux question:
Results 1 to 4 of 4
I'm trying to write data to a floppy disk. I've now got the disk mounted, and I copied the file I want using nautilus. I was a bit suspicious of ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    46

    Writing to a floppy drive


    I'm trying to write data to a floppy disk.

    I've now got the disk mounted, and I copied the file I want using nautilus.

    I was a bit suspicious of the paucity of drive activity, but when I went to a system window, the file was present, and contained the correct info.

    I thought it would be a good idea to unmount the drive before removing the disk, so I tried this, but it just said the drive was busy.

    I took out the disk and looked at it on another machine, and the file was present, but it contained all bytes hex E5.

    I then looked at the file on the Linux box (without putting the disk back in), and, surprise, surprise it was still accessible.

    I assume the data is cached somewher, so I tried reinserting the disk and shutting the system down, hoping that this would clear the cache, but no fd activity took place.

    So: how do I persuade Linux to actually do what I told it to do, and copy a file onto a floppy disk?

  2. #2
    Linux Enthusiast
    Join Date
    Dec 2004
    Location
    Rockin' in the USA!!!
    Posts
    603
    likely the reason it couldn't unmount it was because you were somehow browsing the floppy, either you had it open in nautilus, or you were in the floppy directory. Try exiting out of everything that could be using it and cding to your home folder before unmounting it.

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    46
    No, there is nothing with the floppy open.

    There is just one terminal window open, and that is in /home.

  4. #4
    OMS
    OMS is offline
    Just Joined!
    Join Date
    Dec 2004
    Posts
    29
    You can find out which user and process is using the file system with the fuser command .. kill any process which is using fd0.

    Hope this helps

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •