Find the answer to your Linux question:
Results 1 to 5 of 5
I'm new to Linux and have installed Fedore Core 3 on a laptop. I'm using a Microsoft USB intellimouse, but have tried a Logitech MX510 as well. When web browsing ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    1

    "Back" internet browsing with Mouse question


    I'm new to Linux and have installed Fedore Core 3 on a laptop. I'm using a Microsoft USB intellimouse, but have tried a Logitech MX510 as well. When web browsing I usually use the mouse 4 (thumb button) to browse back one page and Mouse 5 to browse forward. When I use this in Linux it just takes me to the first page in the Location bar drop down list. Same thing happens in both Firefox and Konqurer browsers. Is there a way to bind the mouse buttons to the functions I want? The Mouse config tool in the Preferences/Mouse seems limited to clicking speed and left-hand/right hand options.

    Thank you

  2. #2
    Just Joined! Geomyster's Avatar
    Join Date
    Nov 2006
    Posts
    18
    Any word on this?

  3. #3
    Just Joined!
    Join Date
    Dec 2006
    Location
    Sweden, Stockholm
    Posts
    4
    *bump* I'd also like to know *bump*

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! Geomyster's Avatar
    Join Date
    Nov 2006
    Posts
    18
    I've made a little bit of progress with this, got the backward/forward action to work. -Only works w/ Opera though, not Konq, I don't use firefox, don't know 'bout it. But if it is working in Opera, I'm sure the other browsers just need configured, here's what my xorg.conf looks like:

    Section "InputDevice"
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "Buttons" "10"
    Option "Device" "/dev/input/mice"
    Option "Name" "PS2++ Logitech MX Mouse"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "6 7"
    Option "ButtonMapping" "1 2 3 4 5"
    EndSection

    Hope that helps ya out.

  6. #5
    Just Joined!
    Join Date
    Dec 2006
    Location
    Sweden, Stockholm
    Posts
    4
    Success! My Razer Diamondback behaves properly now. At least, in firefox. Don't know and don't care about any of the others. I googled and found:

    http://ubuntuforums.org/showthread.php?t=192264

    At first I just added the following two lines to my xorg.conf file:

    Option "ZAxisMapping" "4 5"
    Option "ButtonMapping" "1 2 3 6 7"

    and rebooted but that didn't work. Next I tried to also change the protocol from ImPS/2 (the original) to ExplorerPS/2. Rebooted, and: success! Here's the complete section in my xorg.conf file:

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ExplorerPS/2"
    Option "ZAxisMapping" "4 5"
    Option "ButtonMapping" "1 2 3 6 7"
    Option "Emulate3Buttons" "true"
    EndSection

    *happy*

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •