Find the answer to your Linux question:
Results 1 to 8 of 8
Hi, I just installed fedora core 3, Updated with up2date, totaly updated, rebooted linux, installed nvidia drivers etc, rebooted again. But my resolution couldn't get higher then 800x600, so i ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    4

    init 3 problem


    Hi,

    I just installed fedora core 3,

    Updated with up2date, totaly updated, rebooted linux, installed nvidia drivers etc, rebooted again.

    But my resolution couldn't get higher then 800x600, so i installed generic crt 1024x768 display driver, rebooted again and resolution is good.

    But now if i want to go to init 1 2 or 3 i get blank screen and light on monitor goes on and off, i can login but it all goes blind now, and after logging in blindly i can get back to init 5.

    When i shut down linux i get the same black screen, but when i boot linux i just see everything perfectly normal, and if i boot directly to init 3 it works perfect to.

    How do i solve this? please help

    And another problem is when i remove "dri" from xorg.conf it gets back after reboot.

    Greetz

  2. #2
    Linux Enthusiast
    Join Date
    Dec 2004
    Location
    Rockin' in the USA!!!
    Posts
    603
    How did you install the driver, the normal installer will give you instructions for editing your xorg.conf file, I know that your supposed to remove some lines from the module section, although I don't remember off hand. Are you sure that you've removed these, and that you're using the 'nv' driver rather than 'nvidia'?

  3. #3
    Linux User
    Join Date
    Feb 2005
    Posts
    290
    you can always switch to a console terminal by pressing ctrl-alt-F1 or F2-6 (F7 is normally the GUI terminal)

    after ctrl-alt-F1, login as root, then telinit 3 to escape from init level 5, followed by redhat-config-xfree86 (ahem, this is my rh8, not sure about X.org's, please type redhat-config- followed by <tab><tab> to find out the relevant configuration tools) it should have plenty of options ( try --help). one of it which i normally found useful is redhat-config-xfree86 --reconfig

    hope this helps .....

  4. #4
    Just Joined!
    Join Date
    Mar 2005
    Posts
    4
    i have used the instructions on www.fedora-linux.nl, installing the driver in telinit 3 as root, went perfectly, after that i had to edit my xorg.conf file, did that before i started x again with VI, saved the xorg.conf file, and started x with init 5.

    Everything seemed to be fine, but my resolution couldn't get higher than 800x600 so i installed some standard monitor drivers with resolution of 1024x768, after reboot of linux i couldn't get out of GUI. GUI works perfect, but if i want to enter textmode etc the screen just goes out of range or something.

    Maybe the problem is the standard monitor driver, i don't know..
    I also tried to switch to a console terminal, this worked before driver installation but now it doesn't work anymore.

    It seems weird that GUI works eprfect and textmode doesn't

    Please help

  5. #5
    Linux User
    Join Date
    Feb 2005
    Posts
    290
    then try to
    1) make runlevel 3 your default (edit /etc/inittab, look for id:5:initdefault, change 5 to 3, reboot)

    2) login thru console, and startx

    3) when your session is over, logout, and see if your console is "normal"

    if yes, hmm.... guess you would want to stick with this method... don you ?

  6. #6
    Linux Enthusiast
    Join Date
    Dec 2004
    Location
    Rockin' in the USA!!!
    Posts
    603
    I would change the monitor drivers, or whatever you did, and just edit the resolution directly in the xorg.conf file. Fedora has this strange method of changing resolutions based on the monitor specified, and this works fine for most people, but I've never really liked it. Just change the monitor back to whatever you had it to before, and find the line in xorg.conf that says something like:
    Quote Originally Posted by xorg.conf
    Modes 800x600
    and change it to whatever resolution you want, you can also do something like this:
    Quote Originally Posted by xorg.conf
    Modes 1280x1024 1024x768

  7. #7
    Just Joined!
    Join Date
    Mar 2005
    Posts
    4
    i guess i'l try to remove drivers.

    But if i enter my resolution manually the refresh rate is very low, can i enter this manually in xorg.conf also?

    Thnx for the info!

    Greetz

  8. #8
    Just Joined!
    Join Date
    Mar 2005
    Posts
    4
    I tried removing monitor drivers, set them to default 800x600 generic crt drivers.. but still my init 3 doesn't work, linux boots perfectly into GUI, can play UT2004 perfect etc, but tekstmode doesn't work, very weird, can someone help me out with this?

    Thnx

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •