Find the answer to your Linux question:
Results 1 to 3 of 3
Running Fedora core 3. Totally stock out of the box. Got everything to work, needed a few boot options to get things going (mostly noacpi). So, to install the latest ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    2

    X Keyboard works on doesn't work on any new kernel build


    Running Fedora core 3. Totally stock out of the box. Got everything to work, needed a few boot options to get things going (mostly noacpi).

    So, to install the latest NVIDIA driver, and to maybe get my LTWinmodem going, I decided to build my own kernel to have all the headers and such. I used to own a Linux based ISP and used red hat in "the day" so I mostly knew what I was doing.

    Anyway, every kernel I build, 2.6.10 based, 2.6.11 based, boots up, starts X, but the keyboard doesn't work. No errors in the X log, keyboard works in single user mode. I even built the NVIDIA driver, set it up for twin view mode for my TV, that worked, but something easy like the keyboard -- nope. Was cheering when X started, the NVIDIA spash showed up on my TV and PC. But even if I don't build NVIDIA and just install Fedora 3, build a new kernel using the same config as came with Core 3, the keyboard doesn't work in X???

    I know lots of Linux gurus, we are all stumped. I will try booting with a different keyboard when I find it in my garage. I do have a media center PC keybord, but the standard install was happy.

    I was using a debian installation (Mepis), it worked flawlessly -- NVIDIA was built in, my WinModem was recognized, but its a starter distribution, and its just not as clean and slick as Fedora -- but on the other hand, it works

  2. #2
    Linux Enthusiast
    Join Date
    Dec 2004
    Location
    Rockin' in the USA!!!
    Posts
    603
    In the Keyboard section of your xorg.conf file, what does the driver line say, it should prbly use the kbd driver rather than keyboard:
    Quote Originally Posted by xorg.conf
    Driver "kbd"
    Try that, did you compile the keyboard drivers when you compiled the kernel?

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Posts
    2

    Been there, done that

    Yes, I tried both "kbd" and "keyboard" as the X windows driver in Xorg.conf. No difference. Both drivers exist, and look to be the same (same size, same date, different name, maybe just a link(.

    And of course, keyboard support was in the kernel.

    Its just a PS2 keyboard. Works fine in single user mode. Its some X driver problem. I'm traveling, but when I get home I will try an old Microsoft keyboard.

    I do think it did work once with one build. My system is also very picky with kernel options. Nvidia driver install suggested PCI=BIOSIRQ, and I added that, but maybe this mode for Nvidia is confusing my keyboard.

    I'll keep fiddling. Now its just a aggrevating puzzle to solve.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •