I have recently installed Fedora Core 3 and I tried to set up my TV Tuner witch is an Winfast TV 2000 XP Deluxe. I've configured it in modprobe.conf and it's ok (I have all the channels, the image is good), except for the fact that I have absolutely NO sound. I've checked the cable, the alsa mixer, everything. I have absolutely no clue about what's wrong.

Here's how my modprobe.conf looks:

alias eth0 forcedeth
alias eth1 forcedeth
alias scsi_hostadapter sata_sil
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias char-major-81 bttv
alias usb-controller ehci-hcd
alias usb-controller1 ohci-hcd
alias ieee1394-controller ohci1394
alias net-pf-10 off
alias ipv6 off
#TV Tuner Winfast XP 2000 Deluxe configuration
alias char-major-89 i2c-dev
#options i2c-core i2c_debug=1
options i2c-algo-bit bit_test=1
alias char-major-81 videodev
alias char-major-81-0 bttv
alias char-major-81-1 tvaudio
options tuner type=5 debug=1
options bttv card=34 type=5 audiomux=5 pll=1 bttv_gpio=1

I've also tried to set the audiomux on 0 but with no result.
I'm a rookie in Linux so please help!

PS: The tuner works perfectly in Windows XP.