Find the answer to your Linux question:
Results 1 to 6 of 6
Hello All, I am new to Linux so I apologize for the lame question. However, how do create an account that only has FTP access and nothing else, nO SSH, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    1

    FTP ONLY ACCOUNT (VSFTP)


    Hello All,
    I am new to Linux so I apologize for the lame question. However, how do create an account that only has FTP access and nothing else, nO SSH, no shell, nothing?
    I would really appreciate the help.

    Thanks
    ~D

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    in the /etc/passwd file change the user's shell to "/bin/false". AFAIK that should do it.

  3. #3
    Just Joined!
    Join Date
    Feb 2007
    Posts
    3

    CentOS 4 and VSFTP

    What is the proper ending in the /etc/passwd file to keep it so that users can only log in via VSFTP and not have any shell access.

    I have tried

    Code:
    /bin/false
    and login to FTP failed

    Code:
    /bin/noop
    and login to FTP failed

    I am setting up this new server and in my older RH8 /bin/false worked great. Now I can't figure out how to restrict the users.

    Thanks in advance!

  4. #4
    Just Joined!
    Join Date
    Feb 2007
    Posts
    5
    hi,

    You need to configure the ftp server on your computer. for that u need to install "vsftpd " rpm on your computer.

    and then restart the ftp server by using service vsftpd start command.

    after that u be able to login via ftp user.

    if u have any problem the get back.

    best of luck.

  5. #5
    Just Joined!
    Join Date
    Jan 2007
    Posts
    11
    hi,

    you just need to give shell /sbin/nologin and also make the member of ftp group.
    ftp is the primary group of that user.

    Commands for new user:
    useradd -g ftp -s /sbin/nologin <username>

    For old user:
    usermod -g ftp -s /sbin/nologin <username>

  6. #6
    Just Joined!
    Join Date
    Feb 2007
    Posts
    3

    awesome it worked

    thanks ajay.redhat that did the trick.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •