Find the answer to your Linux question:
Results 1 to 7 of 7
Like Tree1Likes
  • 1 Post By oz
Hi - I installed fedora core 3.0 for the first time 2 days ago on a single partition, including GNOME and all the desktop stuff. It seems to be working ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    2

    cannot play music CD's


    Hi -

    I installed fedora core 3.0 for the first time 2 days ago on a single partition, including GNOME and all the desktop stuff. It seems to be working okay, except I cannot play music CD's. I get a drive error, without any further information. I installed fedora from CD's, so I know the drive is working.

    Any suggestions would be appreciated.

    - M

  2. #2
    Linux Newbie
    Join Date
    Feb 2005
    Location
    England
    Posts
    123
    This comes up sooo often in fedora - luckly easy to fi

    Go System settings ->Users and Groups

    at least I think thats how u get to the users and groups programme, its sumwhere in the menue.

    THen click on your username, and then click on something called settings or preferneces (I cant remember cos i dnt hav my linux machine wiv me.) THe right one will have a tab called groups. THen add yourself to the groups called cdrom, dvd, etc, or if in doubt, all except for root. Now you have the privlages to axcess the cdrom drive.

    There is, however, another step that needs to be taken, you need to point the cd player to the drive. The app called cd player should recognise it automatically, but if you use something like xine, go to settings, then in xine its a tab called media, then next to cd drive, type the location of your cd drive:

    It will be either:

    dev/hda
    dev/hdb
    dev/hdc
    dev/hdd

    depending on how the drives are positioned. Whe your pc starts up it will tell u the disks are primary master etc. IN the same order here is what the devices stand for:

    primary master
    primary slave
    secondary master
    secondary slave

    That should fix it for you, but also, if you are trying to play it by mounting the drive and looking for the files, don't.

    An audio cd cannot be mounted, it is written in a different way. Windows pretends to mount audio cds, hence all files are recognized as 1kb.

    Hope this helps, Alan

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Posts
    3

    Music CDs

    I had this problem - the solution was: Using System Tools, Hardware Browser select CD-ROM drives and note the name of the CD-ROM drive in question, mine was /dev/hdd
    Make sure you are a member of the group indicated by clicking on 'Computer' ( on the desktop), then right click CD-ROM drive, select properties then permissions.. Assuming this is now OK, click on 'Applications' ( top of desktop), select 'sound and video', select CD player - open ( left click) 'preferences' ( icon - crossed spanner and screwdriver) and now check the 'device name is right e.g. in my case /dev/hdd change it if not and everything should be good-oh.

    Best of luck!

  4. #4
    Just Joined!
    Join Date
    May 2005
    Posts
    2

    cannot play music CD's

    These suggestions were very helpful, and seemed to correct part of the problem. I'm no longer getting a drive error, but the CD's still will not play.

    I found the drive name for the CD drive is dev/hdc and was able to change the properties of the cd player to point to the correct location. Note that I had to log on as root to make the change.

    Afterwards, music CD's now correctly show the title of the CD, the artist, and list all the songs, but do not play.

    I've tested the sound card and it works fine.

    I've changed my permissions to be a member of every group (excluding and including root). And I've tried playing CD's after logging on as root.

    The CD player can also succesfully eject the CD.

    Any further suggestions or ideas would be appreciated.

    Thanks,

    - M

  5. #5
    Linux User
    Join Date
    Jan 2005
    Location
    Florida
    Posts
    414
    you need to have an analog cable connected between your cdrom and your soundcard. I had the same problem, all sounds played fine except when i tried to play cd's. After trying every solution that didn't involve unplugging my pc I finally hooked up that dang cable and voila! I found the music
    Here is the link to my thread, you might be able to find a better explanation here.http://www.linuxforums.org/forum/top...tml&highlight=
    registered linux user: 387197

  6. #6
    Just Joined!
    Join Date
    Nov 2011
    Posts
    5
    Quote Originally Posted by alancooney View Post
    This comes up sooo often in fedora - luckly easy to fi

    Go System settings ->Users and Groups

    at least I think thats how u get to the users and groups programme, its sumwhere in the menue.

    THen click on your username, and then click on something called settings or preferneces (I cant remember cos i dnt hav my linux machine wiv me.) THe right one will have a tab called groups. THen add yourself to the groups called cdrom, dvd, etc, or if in doubt, all except for root. Now you have the privlages to axcess the cdrom drive.

    There is, however, another step that needs to be taken, you need to point the cd player to the drive. The app called cd player should recognise it automatically, but if you use something like xine, go to settings, then in xine its a tab called media, then next to cd drive, type the location of your cd drive:

    It will be either:

    dev/hda
    dev/hdb
    dev/hdc
    dev/hdd

    depending on how the drives are positioned. Whe your pc starts up it will tell u the disks are primary master etc. IN the same order here is what the devices stand for:

    primary master
    primary slave
    secondary master
    secondary slave

    That should fix it for you, but also, if you are trying to play it by mounting the drive and looking for the files, don't.

    An audio cd cannot be mounted, it is written in a different way. Windows pretends to mount audio cds, hence all files are recognized as 1kb.

    Hope this helps, Alan
    I have the same problem, when I insert a music CD it doesn't play. I think this happens because I changed BIOS to start with CD/DVD then the hard drive. I have very little knowled of Linux but I think that your indications are close to what I need. Can you please give the same indications with more detail? Thank you.

  7. #7
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Hello and welcome!

    This thread is well over 6 years old so I'm going to lock it, but please feel free to start a fresh thread of your own if you need any help with Linux.

    Thank you.
    unist likes this.
    oz

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •