Find the answer to your Linux question:
Results 1 to 3 of 3
i have to mount the windows partions everytime i log in fc3 by #mount -t vfat /dev/hda1 /mnt/win_c and so on for other partitions. .I edited fstab so that they ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Jan 2005
    Location
    India
    Posts
    110

    unable to mount fat32 partitions on fc3


    i have to mount the windows partions everytime i log in fc3 by
    #mount -t vfat /dev/hda1 /mnt/win_c
    and so on for other partitions.
    .I edited fstab so that they are mounted permanently but whenever i logout or reboot they are unmounte and on login i have to go thru the whole procedure of mounting them manually again.
    my fstab looks like:

    # This file is edited by fstab-sync - see 'man fstab-sync' for details
    LABEL=/ / ext3 defaults 1 1
    none /dev/pts devpts gid=5,mode=620 0 0
    none /dev/shm tmpfs defaults 0 0
    LABEL=/home1 /home ext3 defaults 1 2
    none /proc proc defaults 0 0
    none /sys sysfs defaults 0 0
    LABEL=SWAP-hda11 swap swap defaults 0 0
    /dev/hda1 /mnt/win_c vfat users,rw,owner,unmask=000 0 0
    /dev/hda2 /mnt/win_f vfat users,rw,owner,unmask=000 0 0
    /dev/hda5 /mnt/win_d vfat users,rw,owner,unmask=000 0 0
    /dev/hda6 /mnt/win_k vfat users,rw,owner,unmask=000 0 0
    /dev/hda7 /mnt/win_e vfat users,rw,owner,unmask=000 0 0
    /dev/hda8 /mnt/win_j vfat users,rw,owner,unmask=000 0 0
    /dev/hdd /media/cdrecorder auto pamconsole,fscontext=system_u:object_r:removable_t ,ro,exec,noauto,managed 0 0
    /dev/fd0 /media/floppy auto pamconsole,fscontext=system_u:object_r:removable_t ,exec,noauto,managed 0 0





    and the error when i say #mount -a

    [root@mysterio tarun]# mount -a
    [mntent]: warning: no final newline at the end of /etc/fstab
    mount: wrong fs type, bad option, bad superblock on /dev/hda1,
    or too many mounted file systems
    mount: wrong fs type, bad option, bad superblock on /dev/hda2,
    or too many mounted file systems
    mount: wrong fs type, bad option, bad superblock on /dev/hda5,
    or too many mounted file systems
    mount: wrong fs type, bad option, bad superblock on /dev/hda6,
    or too many mounted file systems
    mount: wrong fs type, bad option, bad superblock on /dev/hda7,
    or too many mounted file systems
    mount: wrong fs type, bad option, bad superblock on /dev/hda8,
    or too many mounted file systems




    please suggest something to fix it.have i edited my fstab correctly or not ?if there is something missing then do tell me
    thx

  2. #2
    scm
    scm is offline
    Linux Engineer
    Join Date
    Feb 2005
    Posts
    1,044
    There's no such option as "unmask", it's "umask". That may be causing your problems, so fix that and get back to us if it's still not working.

    Steve

  3. #3
    Linux Newbie
    Join Date
    Jan 2005
    Location
    India
    Posts
    110
    dude thanx a lot
    it worked out.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •