Find the answer to your Linux question:
Results 1 to 10 of 10
Hello, I have the same problem when i try connect apache , like 127.0.0.1/info.php . And i have this error : Forbidden You don't have permission to access /info.php on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Posts
    1

    apache 403 forbidden


    Hello, I have the same problem when i try connect apache , like 127.0.0.1/info.php .

    And i have this error :

    Forbidden

    You don't have permission to access /info.php on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2.0.54 (Fedora) Server at 127.0.0.1 Port 80

    What can i do ???

    Permissions :

    rwxrwxr-x 1 nobody nobody
    drwxr-xr-x 7 nobody nobody

    ps: Sorry my english...

  2. #2
    Just Joined!
    Join Date
    Jun 2005
    Posts
    27
    Post your httpd.conf ... you may not have set DocumentRoot permissions correctly

  3. #3
    Linux User
    Join Date
    Feb 2005
    Posts
    290
    what does it say in your log file? (/var/log/httpd)

  4. #4
    Linux User
    Join Date
    Feb 2005
    Posts
    290
    i got hit by this today, when i tried to configure UserDir on my new centos 4.1, the culprit? SELinux. What i did? disable it.... tada....

  5. #5
    Just Joined!
    Join Date
    Jun 2005
    Posts
    1

    same problem

    i'm having the same problem and i looked at my httpd.conf file as sugested and it is totaly empty what do i right in it i'm new to this and could probably edit it if something was there, what should i do? could someone send me their httpd.conf files some i have someplace to start

    Also in the HTTP server setings it's looking for:
    a 'lock file' /var/lock/httpd.lock but thee file is not there, just 2 folders 'subsys' and 'lvm' and a 'PID file' /var/run/httpd.pid that one is there but all it contains '1780'

    can someone help i would like to get at least one thing working on linux

    -Ryan

  6. #6
    Just Joined!
    Join Date
    Jun 2006
    Posts
    1
    In my FC5, I must set the right selinux permission. So, if you are running selinux on, check the permission of the directory after doing a chmod 755 <your directory> by issuing a ls -aZ. The permission should be root:object_r:httpd_sys_content_t. If not do
    chcon -R root:object_r:httpd_sys_content_t <your directory>.

  7. #7
    Just Joined!
    Join Date
    Jul 2006
    Posts
    10
    Quote Originally Posted by maos
    Hello, I have the same problem when i try connect apache , like 127.0.0.1/info.php .

    And i have this error :

    Forbidden

    You don't have permission to access /info.php on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2.0.54 (Fedora) Server at 127.0.0.1 Port 80

    What can i do ???

    Permissions :

    rwxrwxr-x 1 nobody nobody
    drwxr-xr-x 7 nobody nobody

    ps: Sorry my english...
    Having the same issues (not with english)
    Used to be able to just add modules, now it wants me to add dso's for the userdir in apache 2
    been clicking the keys for 3 days now... any suggestions?
    using mandriva..... freebsd in a few days but mandriva for now as a test box

  8. #8
    Just Joined!
    Join Date
    Jul 2006
    Posts
    10

    my httpd......

    I know its and internal ip ( i have that up just fine) its the userdir's that come up forbidden. And yes, I have all set to 755

    I will start from here

    in the dso section I uncommented the following after downloading mod_userdir.so and putting it into the correct directory

    LoadModule userdir_module modules/mod_userdir.so


    and added
    #
    # UserDir: The name of the directory that is appended onto a user's home
    # directory if a ~user request is received.
    #
    # The path to the end user account 'public_html' directory must be
    # accessible to the webserver userid. This usually means that ~userid
    # must have permissions of 711, ~userid/public_html must have permissions
    # of 755, and documents contained therein must be world-readable.
    # Otherwise, the client will only receive a "403 Forbidden" message.
    #
    # See also: http://httpd.apache.org/docs/misc/FAQ.html#forbidden
    #
    <IfModule mod_userdir.c>
    #
    # UserDir is disabled by default since it can confirm the presence
    # of a username on the system (depending on home directory
    # permissions).
    #
    #UserDir "disable"

    #
    # To enable requests to /~user/ to serve the user's public_html
    # directory, use this directive instead of "UserDir disable":
    #
    UserDir public_html

    </IfModule>




    shouldnt this be all that is needed?

  9. #9
    Linux Enthusiast
    Join Date
    Dec 2004
    Posts
    637
    Open your httpd.conf file as SU and add php.info in the document root section of the file and restart Apache and this should cure the problem. Remember, you must edit this file as root or you will only see a read only file.

  10. #10
    Just Joined!
    Join Date
    Jul 2006
    Posts
    10
    Quote Originally Posted by gtmtnbiker98
    Open your httpd.conf file as SU and add php.info in the document root section of the file and restart Apache and this should cure the problem. Remember, you must edit this file as root or you will only see a read only file.
    This is what it looks like:

    #
    # DocumentRoot: The directory out of which you will serve your
    # documents. By default, all requests are taken from this directory, but
    # symbolic links and aliases may be used to point to other locations.
    #
    DocumentRoot "/home/www/htdocs/"


    How should it read? I am a little confused by your statement, sorry to have you clarify

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •