Find the answer to your Linux question:
Results 1 to 3 of 3
Sorry if this has been addressed before; I looked a lot online and searched here, found nothing so far. I have an odd problem with DVDs. They start out fine ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Location
    college, ny
    Posts
    4

    dvd skipping


    Sorry if this has been addressed before; I looked a lot online and searched here, found nothing so far.

    I have an odd problem with DVDs. They start out fine -- low CPU usage, movie plays without problems. Every couple minutes, though, CPU usage jumps a bit, more or less in steps (not very gradual). Eventually it reaches 100%, and soon afterwards the movie starts skipping to the point of being unwatchable.

    I've tried the "hdparm -d1 /dev/dvd" trick, it doesn't help at all. I not even sure if this is a problem with my DVD drive, or the software. Basically, I'm not even sure where to start asking questions. Anyone have any clue?

  2. #2
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Try this link. I think it came down to optimum order for loading modules.
    /IMHO
    //got nothin'
    ///this use to look better

  3. #3
    Just Joined!
    Join Date
    Jun 2005
    Location
    college, ny
    Posts
    4
    Thanks, drakebasher. I took a look at that link and the "answer here" link on that page, which had to do with reordering the modules. But I don't have an /etc/modules file. I have an /etc/modprobe.conf, but it looks quite different:

    Quote Originally Posted by /etc/modules (from the link)
    sd_mod
    psmouse
    mousedev
    ide-cd
    ide-disk
    ide-generic
    lp
    Quote Originally Posted by but my /etc/modprobe.conf file
    alias eth0 b44
    alias eth1 orinoco_cs
    alias snd-card-0 snd-intel8x0
    options snd-card-0 index=0
    options snd-intel8x0 index=0
    remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
    alias usb-controller ehci-hcd
    alias usb-controller1 uhci-hcd
    That page also had a link to this, which suggested modifying /etc/hdparm.conf, another file that I don't have.

    To clarify, turning dma seems to work fine:
    Code:
    # hdparm -d1 /dev/dvd
    
    /dev/dvd:
     setting using_dma to 1 (on)
     using_dma    =  1 (on)
    So I'm still lost :( I also find it weird that the choppyness only comes after a few minutes, which I haven't found as a specific symptom anywhere else.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •