Find the answer to your Linux question:
Results 1 to 7 of 7
Hi everybody, after upgrading to FC4 I can not longer switch to tty1..6 (Ctrl+Alt+F1..6) since all I see is a black screen. The text modes are ok when booting until ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    16

    black screen on tty1


    Hi everybody,

    after upgrading to FC4 I can not longer switch to tty1..6 (Ctrl+Alt+F1..6) since all I see is a black screen. The text modes are ok when booting until X is loaded, then I don't see text anymore (even when turning off my pc, I don't see anything (black screen)).

    any ideas of this weird behaviour?

    Thx in advance
    Claudio

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Can you post up the contents of your /etc/inittab please?

  3. #3
    Linux Newbie
    Join Date
    Apr 2005
    Location
    NJ, USA
    Posts
    104
    If you are booting X in your /etc/inittab then you will not have any ttys open. If you were running slackware however tty 6 would be open
    My New years Resolution is 1280x1024

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    I always have ttys 1-6 open even when in X, that's in SuSE and Mandriva. I would recommend checking /etc/inittab for which runlevels allow which ttys to be open. If you post it here I will show you where.

  6. #5
    Just Joined!
    Join Date
    Nov 2004
    Posts
    16
    Here is my /etc/inittab (after removing comments)

    id:5:initdefault:
    si::sysinit:/etc/rc.d/rc.sysinit
    l0:0:wait:/etc/rc.d/rc 0
    l1:1:wait:/etc/rc.d/rc 1
    l2:2:wait:/etc/rc.d/rc 2
    l3:3:wait:/etc/rc.d/rc 3
    l4:4:wait:/etc/rc.d/rc 4
    l5:5:wait:/etc/rc.d/rc 5
    l6:6:wait:/etc/rc.d/rc 6
    ca::ctrlaltdel:/sbin/shutdown -t3 -r now
    pf:owerfail:/sbin/shutdown -f -h +2 "Power Failure; System Shutting Down"
    pr:12345owerokwait:/sbin/shutdown -c "Power Restored; Shutdown Cancelled"
    1:2345:respawn:/sbin/mingetty tty1
    2:2345:respawn:/sbin/mingetty tty2
    3:2345:respawn:/sbin/mingetty tty3
    4:2345:respawn:/sbin/mingetty tty4
    5:2345:respawn:/sbin/mingetty tty5
    6:2345:respawn:/sbin/mingetty tty6
    x:5:once:/etc/X11/prefdm -nodaemon

  7. #6
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    The tty parts look fine to me, I will pull this apart further this evening.

  8. #7
    Just Joined!
    Join Date
    Nov 2004
    Posts
    16
    I think the /etc/inittab has not changed after upgrading to FC4, and I didn't have this problem with older FC versions... Any help would be appreciated.

    Thx!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •